1. Проверка данных выпуска

1.1. Общие сведения

Результаты обработки данных радиозондирования в выходных файлах, создаваемых программным обеспечением МАРЛ-А, Вектор-М и модернизированных АВК, могут содержать недостоверные данные, которые должны выявляться в рамках оперативного (перед подачей сообщения BUFR), технического и критического контроля качества информации (для подачи исправленных сообщений BUFR).

Недостоверные данные должны быть исключены из передаваемых сообщений независимо от того, используется ли традиционный код КН-04 ТЕМП или код BUFR. Однако, поскольку в сообщении BUFR результаты радиозондирования передаются с максимально подробной дискретностью и их объем существенно превышает объем данных, передаваемых в аэрологических телеграммах КН-04 ТЕМП, высока вероятность того, что в сообщение BUFR попадут недостоверные данные. Поэтому вопросам проверки данных при отправке сообщений BUFR необходимо уделять большее внимание, чем при отправке традиционных телеграмм.

Как известно, источником недостоверных результатов обработки могут быть не только недостоверные исходные данные (замирания сигнала и отказы телеметрии радиозонда, срывы сопровождения и т.д. и т.п.), но и ошибки обработки. Программное обеспечение обработки данных новых АРВК, к сожалению, не предусматривают самой возможности пропусков в результатах обработки, которые могут быть связаны с отсутствием или поступлением недостоверных исходных данных. Вместо этого либо, при выполнении соответствующих критериев, обработка прекращается, либо производится интерполяция отсутствующих данных в слое с пропуском наблюдений. При этом очень часто такая интерполяция бывает неадекватной.

При передаче аэрологических данных в традиционном коде КН-04 аэрологи перед отправкой вручную исключают недостоверные данные, заменяя на символы «/» соответствующие группы и кодовые цифры в аэрологических телеграммах. В коде BUFR вместо символов «/» для обозначения отсутствующих данных передается код отсутствия, однако, поскольку код BUFR бинарный и предназначен для формирования его компьютером, его непосредственное редактирование/правка/корректировка практически невозможно. Для замены в коде BUFR недостоверных значений метеовеличин на код отсутствия необходимы специализированные программные средства.

При подготовке к отправке сообщений в коде BUFR не следует прибегать к ручной правке выходных файлов, создаваемых программным обеспечением АРВК (TAE3, TAE03 или, тем более, prof). Опыт контроля файловых архивов данных радиозондирования показывает, что при удалении из них недостоверных данных или, тем более, попытках их исправления, вероятность ошибок очень высока. Кроме того, нарушения формата выходных файлов могут привести к ошибкам при их чтении Программой и сделают формирование сообщений BUFR невозможным.

Не следует вносить вручную изменения в результаты радиозондирования в выходных файлах систем автоматической обработки – ПО UABUFR содержит встроенные средства, позволяющие исключить их из передачи при формировании и отправке сообщений в коде BUFR.

2. Форма проверки данных перед отправкой

Форма проверки данных перед отправкой предназначена для формирования и сохранения массива признаков для исключения недостоверных данных из формируемого сообщения BUFR.

Данные, отмеченные признаками исключения, или забракования, исключаются из передаваемого сообщения BUFR – вместо них передается коды отсутствия, что аналогично передаче символов «/» в традиционных кодах, таких как КН-04 ТЕМП. Признаками исключения могут быть помечены отдельные значения метеовеличин (температура, точка росы, геопотенциал, направление и скорость ветра, координаты), весь уровень или целый слой. В последнем случае этот уровень или весь слой, включающий несколько последовательных уровней, не включается в формируемое сообщение BUFR.

Форма проверки данных перед отправкой позволяет до формирования и передачи сообщения в коде BUFR с результатами радиозондирования:

· Загрузить ранее сохраненный массив признаков забракования из файла на жестком диске ПЭВМ.

· Просмотреть результаты обработки в табличном и графическом виде;

· Локализовать недостоверные данные, выявленные в ходе технического или критического просмотра;

· Установить или отменить признаки забракования для отдельных или всех метеовеличин на отдельном уровне или в слое;

· Отобразить в наглядном виде в табличном и графическом представлении забракованные метеовеличины и уровни;

· Сохранить для последующего использования массив признаков забракования в файле на жестком диске ПЭВМ.

3. Описание операций

3.1. Загрузка данных выпуска и сохраненных результатов правки

После нажатия кнопки «BUFR I» или «BUFR II» в главном окне, ПО UABUFR находит в архиве данных выпусков и загружает результаты обработки из файлов, сформированных соответствующим ПО обработки данных радиозондирования, используемым применяемой системой радиозондирования (подробнее см. UABUFRInstr.doc и • UABUFRTrain.doc). В процессе загрузки могут выдаваться запросы на подтверждение продолжения формирования сообщения BUFR или сообщения об ошибках.

Запросы выдаются:

· В случае несоответствия информации о выпуске, введенной оператором в главном окне ПО, ранее сохраненной информации или информации, содержащейся в исходных файлах. Оператор имеет возможность принять решение об использовании ранее сохраненной или вновь введенной информации или вернуться в главное окно ПО.

· В случае отсутствия тех или файлов, например – файлов GLAYER с данными в приземном слое или RAWDATA с координатно-телеметрическими данными в системе АВК-АП «ЭОЛ». Оператор имеет возможность принять решение о продолжении подготовки сообщения BUFR или вернуться в главное окно ПО. ВНИМАНИЕ: Формирование и отправка сообщений в коде BUFR без учета информации в одном или нескольких исходных файлах в случае их отсутствия допускается только, если соответствующий файл или файлы не удается сформировать из-за ошибок ПО системы радиозондирования.

· В случае наличия ранее сохраненной информации о признаках забракования выдается запрос на ее использование в текущем сеансе правки данных. Поскольку признаки забракования сохраняются как при формировании сообщения BUFR с данными до уровня 100 гПа, так и по завершению выпуска – с данными всего выпуска, может быть выдан один из запросов:

- «Обнаружены результаты правки данных до 100 гПа:<Файловое имя выпуска>»;

- «Обнаружены результаты правки данных всего выпуска:<Файловое имя выпуска>»;

- «Обнаружены результаты правки данных выпуска <Файловое имя выпуска>:до 100 гПа и всего выпуска».

Оператор имеет возможность выбрать для использования сохраненные результаты правки данных до уровня 100 гПа или, если имеются, результаты правки данных всего выпуска, игнорировать ранее сохраненные результаты правки, или вернуться в главное окно ПО.

Сообщения об ошибках на этом этапе могут включать:

· Сообщения о сбоях или ошибках при загрузке исходных данных. Даже если сбои или ошибки не привели к невозможности формирования сообщения BUFR, оператору при просмотре и правке данных необходимо убедиться в адекватности передаваемых данных.

· Сообщения об ошибках при загрузке сохраненных результатов правки: результаты правки привязаны к количеству уровней. Если в результате последующей обработки исходных данных изменилось общее количество уровней с результатами обработки или количество уровней с результатами обработки до 100 гПа, использование ранее сохраненных результатов правки невозможно. Оператор имеет возможность продолжить просмотр данных без использования сохраненных результатов правки или вернуться в главное окно ПО.

3.2. Просмотр и правка данных

Если вместе с результатами обработки были загружены сохраненные результаты правки данных и после их сохранения, оператору необходимо внимательно убедиться в корректности применения сохраненных результатов забракования к вновь полученным результатам обработки, в особенности, если при этом изменилось количество уровней с результатами обработки. Если сохраненные результаты правки неприменимы, оператору следует либо вручную отменить признаки забракования либо отказаться от продолжения работы, нажав кнопку «Отмена», повторно нажать кнопку «BUFR I» или «BUFR II» в главном окне и нажать кнопку «Игнорировать сохраненные правки» в диалоге запроса, чтобы игнорировать сохраненные результаты правки при загрузке результатов обработки:

Рисунок 1. Запрос на загрузку сохраненных результатов правки

При просмотре данных необходимо идентифицировать недостоверные данные, используя табличное и графическое представление результатов обработки, локализовать и выделить в таблице данных уровни с недостоверными данными и установить для них признаки забракования, используя соответствующие кнопки на панели инструментов. При необходимости, можно отменить установку признаков забракования, как загруженных по результатам предшествующих сеансов, так и установленных в текущем сеансе просмотра и правки данных.

После завершения редактирования признаков забракования для недостоверных данных для перехода к формированию и отправке сообшения в коде BUFR нужно нажать кнопку «ОК». В зависимости от того, изменялись ли признаки забракования в текущем сеансе, выдается запрос на продолжение, соответственно – «Данные подвергались правке!» или «Правка не производилась!» и оператору предлагается альтернатива: вернуться к правке или отправить с изменениями или без изменений (если правка не производилась).

Если по каким-либо причинам необходимо отказаться от формирования и отправки сообщения BUFR, нужно нажать кнопку «Отмена». При этом, если в текущем сеансе правки производились изменения признаков забракования, выдается запрос на сохранение результатов правки. Если результаты правки были сохранены, их можно будет использовать позднее.

Рисунок 2. Запрос на сохранение результатов правки

3.3. Сохранение результатов правки

При штатном завершении сеанса правки (по нажатию кнопки «ОК»), если была забракована хотя бы одна метеовеличина, результаты правки – массив признаков забракования сохраняется на диске в папке, где находятся файлы с результатами обработки, в файл с файловым именем выпуска в качестве имени и расширением rjI, если проверялись данные вплоть до уровня 100 гПа, и rjII, если проверялись данные всего выпуска. При этом файлы с сохраненными в предыдущих сеансов проверки данных выпуска признаками забракования затираются.

4. Описание окна проверки данных перед отправкой

4.1. Представление информации

Внешний вид окна формы представлен на рис.3 (представлены результаты выпуска, проанализированного в разделе 4 методического пособия «Анализ координатно-телеметрических данных современных систем радиозондирования», рисунок 4.8 - http://cao-ntcr.mipt.ru/monitor/rawdoc/rd_ch4.pdf).

Панель с кнопками управления

Панель с таблицей данных выпуска

Панель с диаграммами профилей метеовеличин

Рисунок 3. Интерфейс окна формы проверки данных перед отправкой

В заголовке окна формы указывается файловое имя выпуска. Если в текущем сеансе проверки данных выпуска производилась правка данных, к имени файлов добавляется символ «*». Символ «*» к файловому имени не добавляется, если при загрузке данных выпуска одновременно были загружены сохраненные (в предыдущих сеансов проверки данных выпуска) признаки исключения недостоверных данных.

Под заголовком окна формы расположена панель с кнопками управления (панель инструментов), под которой находится рабочая область формы, представляющая результаты выпуска в текстовом и графическом виде.

В левой части рабочей области размещена панель с таблицей данных выпуска, которые будут передаваться в сообщении BUFR. В правой – панель, в которой отображаются диаграммы с данными температуры, влажности, геопотенциала, ветра и траекторией полета радиозонда. Между панелью данных и панелью диаграмм находится вертикальная разделительная черта. При наведении на нее курсора мыши значок курсора принимает вид , как показано на рис. 3. После этого, нажав и удерживая левую кнопку мыши и перемещая мышь влево или вправо, можно изменить размер панели данных за счет размера панели диаграмм.

4.2. Панель инструментов

На панели инструментов в крайней левой позиции расположен снабженный меткой «F1->» выпадающий список (на него указывает стрелка выноски «Панель с кнопками управления» на рис. 1) для выбора режима установки признаков исключения недостоверных данных, которые условно обозначены символами «-», «+» и «±», соответствующие следующим режимам:

· «-» - установка признака исключения для соответствующей метеовеличины, уровня или слоя;

· «+» - отмена установки признака исключения для соответствующей метеовеличины, уровня или слоя, для которых он уже установлен;

· «±» - переключение установки признака исключения, т.е. для соответствующей метеовеличины, уровня или слоя, признак исключения устанавливается, если он не был установлен, и отменить установку этого признака, если он установлен, этот режим выбран по умолчанию.

После выбора нужного режима его условное отображения добавляется к названиям расположенных справа от списка выбора режима кнопок для установки признака исключения недостоверных данных:

· «Урвн(F2)» - устанавливает в соответствии с текущим режимом признак исключения недостоверных данных для всех метеовеличин на уровне или в слое, выбранном в таблице данных выпуска;

· «T(F3)» - устанавливает в соответствии с текущим режимом признак исключения недостоверных данных для всех температуры на уровне или в слое, выбранном в таблице данных выпуска. Установка признака исключения для температуры одновременно автоматически устанавливает признак исключения и для точки росы, однако отмена признака исключения для температуры не приводит к отмене признака исключения и для точки росы;

· «dT(F4)» - устанавливает в соответствии с текущим режимом признак исключения недостоверных данных для точки росы на уровне или в слое, выбранном в таблице данных выпуска;

· «H(F5)» - устанавливает в соответствии с текущим режимом признак исключения недостоверных данных для геопотенциальной высоты на уровне или в слое, выбранном в таблице данных выпуска;

· «W(F6)» - устанавливает в соответствии с текущим режимом признак исключения недостоверных данных для направления и скорости ветра на уровне или в слое, выбранном в таблице данных выпуска;

· «XY(F7)» - устанавливает в соответствии с текущим режимом признак исключения недостоверных данных для смещения радиозонда на уровне или в слое, выбранном в таблице данных выпуска.

Кнопка «Сброс» отменяет установку признаков исключения для всех метеовеличин, уровней и слоев, т.е. в результате ее применения все данные в таблице выпуска признаются достоверными и будут включены в формируемое сообщение BUFR.

Кнопка подгоняет вертикальный масштаб диаграмм TH и DV и масштаб диаграммы XY в соответствии с текущим выбором уровня или слоя в таблице с данными выпуска.

Кнопка восстанавливает исходный масштаб всех диаграмм.

Нажатие кнопки «ОК» завершает сеанс проверки данных выпуска, после закрытия формы проверки данных выпуска формируется сообщение BUFR и производится его отправка в соответствии с текущими установками. Перед закрытием формы программа выдается запрос на подтверждение. Если производилась правка, выдается запрос «Данные подвергались правке! Отправить с изменениями?», а если не производилась – «Правка не производилась! Отправить без изменений?». Если оператор не подтверждает запрос на отправку, текущий сеанс правки продолжается.

Нажатие кнопки «Отмена» завершает сеанс проверки данных выпуска и отменяет формирование и отправку сообщения BUFR. Если в текущем сеансе проверки данных выпуска оператор изменял установки признаков недостоверных данных, выдается запрос на подтверждение выхода. При этом имеется возможность принять и сохранить внесенные изменения для последующего использования (например, если по каким-либо причинам приходится отложить отправку сообщения в коде BUFR).

Обозначения F1-F9 на вышеуказанных органах управления соответствуют функциональным клавишам клавиатуры, нажатие которых дублирует действие соответствующих кнопок (более подробно см. раздел «Использование клавиатуры».

Рисунок 4. Отображение траектории полета радиозонда

4.3. Панель данных выпуска

На панели данных выпуска размещена таблица с данными выпуска, сверху которой размещен заголовок. Текст заголовка отрисовывается шрифтом белого цвета на темно-синем фоне, когда таблица данных активна (имеет фокус ввода – реагирует на клавиатуру), и шрифтом темно-синего цвета на белом фоне, когда она неактивна. Метки заголовка обозначают следующие данные в соответствующих колонках таблицы:

t – полетное время, с

P – давление, гПа

T – температура, °С

dT – точка росы, °С;

H – геопотенциальная высота, гпм;

D – направление ветра, °;

f – скорость ветра, м/с;

dLat – смещение радиозонда относительно станции по широте,°;

dLon – смещение радиозонда относительно станции по долготе,°;

Flags – признаки уровней (S – уровень поверхности, C – уровень стандартной изобарической поверхности, T – уровень особой точки по температуре, U – уровень особой точки по влажности, W– уровень особой точки по ветру[1], M – уровень максимального ветра, R – уровень тропопаузы).

Отсутствующие данные отображаются символом «-». Значения метеовеличин, для которых установлен признак исключения недостоверных данных, отображаются перечеркнутым шрифтом. При этом строки с данными уровней, содержащих забракованные значения метеовеличин, отрисовываются темно-коричневым шрифтом на светло-сером фоне, а в начале этих строк выводится символ «x», если забракованы все имеющиеся данные на соответствующих уровнях (такие уровни будут исключены из формируемого сообщения BUFR), или символ «?», если забраковано значение хотя бы одной из метеовеличин. Строки с данными уровней, не содержащих забракованные значения метеовеличин, выводятся шрифтом черного цвета на белом фоне.

В отличие от диаграмм, распространяющихся на все доступное выделенное пространство окна панели диаграмм, таблица данных, как правило, целиком в окне панели данных не помещается. В зависимости от разрешения монитора, часть правых колонок заголовка и таблицы может быть скрыта. Справа и снизу таблицы имеются стандартные для интерфейса Windows полосы прокрутки, которые позволяют с помощью мыши «прокрутить» таблицу по вертикали или горизонтали, чтобы вывести в окно панели требуемые строки или колонки таблицы. Для пролистывания таблицы данных по вертикали можно также использовать колесо прокрутки мыши.

Выделенные строки таблицы отрисовываются шрифтом белого цвета на синем фоне, если соответствующие уровни не содержат забракованных данных. Строки с уровнями, содержащими забракованные данными, при выделении отрисовываются шрифтом голубого цвета на сером фоне.

Для изменения установок признаков забракования необходимо сначала выбрать в таблице данных соответствующие уровень (строку) или слой (несколько строк подряд). Для выделения нужной строки достаточно навести на нее курсор мыши и нажать ее левую кнопку. Для выделения нескольких строк после выделения одной строки нужно переместить мышь вверх или вниз, удерживая ее левую кнопку, или навести курсор мыши на нужную строку выше или ниже уже выделенной и нажать левую кнопку мыши, одновременно нажимая клавишу Shift на клавиатуре. Выбранный уровень или слой отображаются, соответственно, селектором или полосой выделения на диаграммах TH и DV, а принадлежащие выбранному уровню или слою значения координат смещения радиозондов выделяются цветом на диаграмме XY.

Уровни, соответствующие выделенным в таблице данных строкам, выделяются на диаграммах TH и DV селектором (при выделении одного уровня) или полосой выделения (при выделении слоя), а на графике траектории полета радиозонда – измененным цветом точек. Таким образом, всегда можно локализовать для анализа на графиках положение определенного уровня или слоя, выделенного в табличном представлении.

При сопоставлении с диаграммами TH и DV, отображающими вертикальные профили метеовеличин, необходимо принимать во внимание, что, в отличие от диаграмм, данные в таблице выводятся в порядке возрастания высоты (возрастания полетного времени/убывания давления).

После выделения требуемого уровня или слоя можно изменить признаки забракования одной или всех метеовеличин для этого уровня или слоя, воспользовавшись соответствующими кнопками на панели инструментов. Данные на уровне земли забракованию не подлежат.

4.4. Панель диаграмм

Панель диаграмм представляет собой "виртуальный блокнот", на вкладках которого, обозначенных с верхней стороны так называемыми закладками-ярлыками, размещены соответственно:

- на вкладке «TH(F11)» диаграмма с данными температуры, влажности и геопотенциала;

- на вкладке «DV(F12)» диаграмма с графиками профилей направления и скорости ветра;

- на вкладке «XY(Alt+F12)» диаграмма с графиком координат смещения радиозонда относительно станции по широте и долготе (траектория полета радиозонда).

Выбранная вкладка обозначается закладкой, находящейся "поверх" остальных. Выбирая соответствующую вкладку, можно вывести на экран необходимую в данный момент диаграмму, возможность одновременного просмотра нескольких диаграмм в программе не предусмотрена.

4.4.1. Диаграмма TH с данными с температуры, влажности и геопотенциала

На данной диаграмме в зависимости от давления отображаются графики с вертикальными профилями температуры T, точки росы dT и девиация геопотенциальной высоты dH (разница между наблюдаемым значением геопотенциальной высоты и ее значением для стандартной атмосферы при заданном давлении). Графики температуры и точки росы в качестве оси абсцисс используют нижнюю, а график девиации геопотенциала - верхнюю горизонтальную координатную ось. Цвет горизонтальных осей и меток шкал соответствуют цвету графика, используемого для отображения соответствующей величины. Исключение составляет график точки росы, отображаемый пурпурным цветом. На оси ординат (левой вертикальной координатной оси) отложено давление в логарифмическом масштабе в порядке убывания значений – как это принято в аэрологии. Таким образом внизу диаграммы отображаются значения на самых низких, а вверху – на самых верхних уровнях. Значения метеовеличин, для которых установлен признак исключения данных (т.е. фактически - «забракованные» значения), отображаются: температура – синим, точка росы – оранжевым и девиация геопотенциала – светло-зеленым цветом.

4.4.2. Диаграмма DV с данными ветра

На данной диаграмме в зависимости от давления отображаются графики с вертикальными профилями направления D и скорости ветра V. График направления ветра в качестве оси абсцисс используют нижнюю, а график скорости ветра - верхнюю горизонтальную координатную ось. Цвет горизонтальных осей и меток шкал соответствуют цвету графика, используемого для отображения соответствующей величины. Ось ординат аналогична используемой на диаграмме TH. Забракованные значения метеовеличин, для которых установлен признак исключения данных, отображаются: направление ветра – зеленым, а скорости ветра – пурпурным цветом.

4.4.3. Диаграмма XY с траекторией полета радиозонда

На данной диаграмме отображается график координат смещения радиозонда относительно станции по широте и долготе (траектория полета радиозонда). По оси абсцисс откладываются значения смещения радиозонда по долготе, а по оси ординат – по широте. Забракованные значения координат, для которых установлен признак исключения данных, отображаются зеленым цветом, если они не принадлежат уровню или слою, выбранному в таблице данных выпуска. Точки, отображающие забракованные координаты на уровне или в слое, выбранном в таблице данных выпуска, отображаются красным цветом. При просмотре графика траектории радиозонда необходимо учитывать, что значения координат на разных уровнях могут накладываться друг на друга.

4.4.4. Работа с диаграммами

4.4.4.1. Выбор уровня или слоя

Слой, выбранный в таблице данных выпуска, отображается на диаграммах TH и DV выделенной более интенсивной заливкой горизонтальной полосой (полосой выделения) или, если в таблице данных выпуска выбран только один уровень – горизонтальной линией выделения (селектором). На диаграмме XY значения координат, принадлежащие уровню или слою, выбранному в таблице данных выпуска, отображаются голубым цветом, при этом забракованные значения координат отображаются красным цветом.

При наведении курсора мыши на полосу выделения значок курсора принимает вид , как показано на рис. 7. После этого, нажав и удерживая левую кнопку мыши и перемещая мышь вверх или вниз, можно изменить положение полосы выделения.

При наведении курсора мыши на верхнюю или нижнюю границу полосы выделения (если в таблице данных выделен только один уровень – на селектор) значок курсора принимает вид , как показано на рис. 6. После этого, нажав и удерживая левую кнопку мыши и перемещая мышь вверх или вниз, можно изменить размер полосы выделения. При изменении размера или положения изменяется и слой, выделенный в таблице данных выпуска.

При наведении курсора мыши на точку на любом из графиков значок курсора принимает вид и, после некоторой задержки, на диаграмме появляется небольшое окошко с данными этой точки – значением метеовеличины и давлением на соответствующем уровне или, для диаграммы XY – значениями координат, как показано на рис.4. Если при этом нажать левую кнопку мыши, изменится выделение слоя в таблице данных выпуска:

· При работе с диаграммами TH и DV – если выбранная точка находится выше полосы выделения (давление меньше, чем давление на верхней границе полосы выделения), то в таблице данных дополнительно к уже выделенному уровню или слою будут выбраны все уровни выше последнего выбранного уровня вплоть до уровня данной точки. Если точка находится ниже полосы выделения (давление выше, чем давление на верхней границе полосы выделения), то в таблице данных дополнительно к уже выделенному уровню или слою будут выбраны все уровни ниже последнего выбранного уровня вплоть до уровня данной точки.

· При работе с диаграммой XY – если выбранная точка по порядку следования уровней по мере подъема радиозонда находится до точки (точек), принадлежащих выделенному в таблице данных уровню или слое (то есть уровень, соответствующий выбранной точке, находится ниже выделенного слоя), то в таблице данных дополнительно к уже выделенному уровню или слою будут выбраны все уровни ниже последнего выбранного уровня вплоть до уровня данной точки. Если точка по порядку следования уровней по мере подъема радиозонда находится после точки (точек), принадлежащих выделенному в таблице данных уровню или слое (то есть уровень, соответствующий выбранной точке, находится выше выделенного слоя), то в таблице данных дополнительно к уже выделенному уровню или слою будут выбраны все уровни выше последнего выбранного уровня вплоть до уровня данной точки.

Если при наведении курсора мыши на точку на любом из графиков нажать левую кнопку мыши, удерживая клавишу Shift на клавиатуре, или правую кнопку мыши, то в таблице данных будет выделен уровень, соответствующий выбранной точке, а предыдущее выделение будет отменено.

Выделение данных на графиках позволяет найти и выделить в таблице данные, вызвавшие интерес при просмотре диаграмм, для забракования или отмены забракования метеовеличин на выбранном уровне или в выбранном слое.

4.4.4.2. Масштабирование и прокрутка

Диаграммы при создании и обновлении масштабируются автоматически таким образом, чтобы графики заняли все доступное пространство окна диаграммы. Для подробного просмотра выбранного участка диаграммы доступно увеличение, которое осуществляется нажатием левой кнопки мыши с последующим движением мыши вправо и вниз. При этом отображается рамка, обозначающая участок, которые будет увеличен на весь размер окна диаграммы сразу после отпускания кнопки мыши. При увеличении диаграмм TH и DV масштаб горизонтальных осей автоматически подгоняется под диапазон изменения отображаемых величин в выбранном интервале высоты (давления). Для продвинутых пользователей: если при выделении фрагмента для увеличения на этих диаграммах одновременно с левой кнопкой мыши нажать клавишу Shift на клавиатуре, то при увеличении масштаб горизонтальных осей не изменится, а если вместо клавиши Shift нажать клавишу Alt, то будет увеличен выделенный фрагмент. Если был выбран слишком маленький фрагмент, увеличение вернется к исходному масштабу.

Если необходимо увеличить масштаб участка диаграммы TH или DV, занятый полосой выделения, при выделении мышью участка для масштабирования, как описано выше, необходимо дополнительно нажать клавишу Shift на клавиатуре, в противном случае вместо выделения участка диаграммы будет производиться перемещение полосы выделения.

При отображении в увеличенном масштабе можно переместиться к другому участку диаграммы, нажав правую кнопку мыши и, удерживая эту кнопку нажатой, переместив мышь в желаемом направлении. Кроме того, перемещение диаграммы доступно при использовании колеса прокрутки мыши (по вертикали).

Данные, выходящие за физически допустимые области, определения на диаграммах не отображаются. Однако и менее значительные выбросы могут существенно затруднить анализ графиков. На рис. 5 показаны данные ветра, в которых из-за ошибки программы «Телеграмма» при интерполяции данных азимута при его переходе через 0°, данные ветра содержат грубые ошибки.

Если флажок у символа «?» на панели инструментов не установлен, все масштабирование выполняется с учетом забракованных значений метеовеличин, как на рис. 5. Если этот флажок установлен, при всех операциях масштабирования забракованные значения метеовеличин игнорируются, как показано на рис. 6.

Рисунок 5. Масштабирование с учетом забракованных данных.

Вернуться к отображению на диаграмме данных всего выпуска возможно, нажав левую кнопку мыши в любом месте диаграммы и переместив мышь влево и вверх на произвольное расстояние. Если при этом нажать клавишу Shift на клавиатуре, диаграмма отобразится с применением ранее использованного масштаба (если перед этим увеличение диаграммы производилось более одного раза). Если на диаграммах TH или DV полоса выделения занимает всю область диаграммы, для возвращения к исходному масштабу необходимо дополнительно нажать клавишу Shift на клавиатуре, в противном случае будет производиться перемещение полосы выделения.

Дополнительно, как указывалось выше, для масштабирования диаграмм могут использоваться кнопки на панели инструментов.

Рисунок 6. Масштабирование, при котором забракованные данные игнорируются.

4.5. Использование клавиатуры

Практически все действия, необходимые оператору при работе с формой проверки данных, можно выполнить, используя только мышь (только для некоторых операциях – одновременно с нажатием одной-двух клавиш на клавиатуре). Освоение использования мыши не требует больших усилий и позволяет с минимальными затратами на обучение приступить к использованию программных средств.

Тем не менее, при разработке программы большое внимание было уделено возможности использования клавиатуры, так как, несмотря на затраты времени на освоение клавиатурных комбинаций, использование клавиатуры для выполнения однотипных операций обычно более эффективно в практической работы и является единственной альтернативой, обеспечивающей работу с программой при неисправности мыши, что в условиях аэрологических станций, а также облегчает жизнь операторам, неуверенно владеющим мышью.

Ряд функций органов управления дублируется сочетаниями клавиш клавиатуры, которые приведены в нижеследующей таблице. Большую часть из них нет необходимости запоминать, т.к. они обозначены в названиях соответствующих органов управления. Кроме того, если в названии кнопки панели инструментов или ярлыка вкладок панели диаграмм присутствует подчеркнутый символ, одновременное нажатие клавиши Alt и клавиши с соответствующим символом активизирует соответствующий орган управления. Например, нажатие клавиш клавиатуры Alt+9 эквивалентно нажатию кнопки или нажатию клавиши F9.

4.5.1. Перечень «горячих клавиш»

Сочетания клавиш | Действия
Alt+1..Alt+7, Alt+8, Alt+9 | Аналогично действию функциональных клавиш F1…F7, F8, F9
F1 | Активация панели инструментов и списка выбора режима установки признаков забраковани
Shift+F1 | Активация панели инструментов и списка выбора режима правки и выбор режима «‑» установки признаков забракования
Ctrl +F1 | Активация панели инструментов и списка выбора режима правки и выбор режима «+» отмены установки признаков забракования
Ctrl+Shift+F1 | Активация панели инструментов и списка выбора режима правки и выбор режима «±» включения/отключения установок признаков забракования
F2 | Правка признака недостоверности для всех метеовеличин на выбранном уровне или в слое в соответствии с текущим режимом правки: установка, отмена или переключение
Shift+F2 | Забракование всех метеовеличин на выбранном уровне или в слое
Ctrl +F2 | Отмена забракования всех метеовеличин на выбранном уровне или в слое
Ctrl+Shift+F2 | Инвертирование забракования всех метеовеличин на выбранном уровне или в слое
F3 | Правка признака недостоверности для температуры и точки росы на выбранном уровне или в слое в соответствии с текущим режимом правки: установка, отмена или переключение
Shift+F3 | Забракование температуры и точки росы на выбранном уровне или в слое
Ctrl +F3 | Отмена забракования температуры и точки росы на выбранном уровне или в слое
Ctrl+Shift+F3 | Инвертирование забракования температуры и точки росы на выбранном уровне или в слое
F4 | Правка признака недостоверности для точки росы на выбранном уровне или в слое в соответствии с текущим режимом правки: установка, отмена или переключение
Shift+F4 | Забракование точки росы на выбранном уровне или в слое
Ctrl +F4 | Отмена забракования точки росы на выбранном уровне или в слое
Ctrl+Shift+F4 | Инвертирование забракования точки росы на выбранном уровне или в слое
F5 | Правка признака недостоверности для геопотенциальной высоты на выбранном уровне или в слое в соответствии с текущим режимом правки: установка, отмена или переключение
Shift+F5 | Забракование геопотенциальной высоты на выбранном уровне или в слое
Ctrl +F5 | Отмена забракования геопотенциальной высоты на выбранном уровне или в слое
Ctrl+Shift+F5 | Инвертирование забракования геопотенциальной высоты на выбранном уровне или в слое
F6 | Правка признака недостоверности данных ветра на выбранном уровне или в слое в соответствии с текущим режимом правки: установка, отмена или переключение
Shift+F6 | Забракование данных ветра на выбранном уровне или в слое
Ctrl +F6 | Отмена забракования данных ветра на выбранном уровне или в слое
Ctrl+Shift+F6 | Инвертирование забракования данных ветра на выбранном уровне или в слое
F7 | Правка признака недостоверности координат смещения радиозонда на выбранном уровне или в слое в соответствии с текущим режимом правки: установка, отмена или переключение
Shift+F7 | Забракование координат смещения радиозонда на выбранном уровне или в слое
Ctrl +F7 | Отмена забракования координат смещения радиозонда на выбранном уровне или в слое
Ctrl+Shift+F7 | Инвертирование забракования координат смещения радиозонда на выбранном уровне или в слое
F8 | Подгонка масштаба диаграмм в соответствии с текущим выбором уровня или слоя в таблице с данными выпуска
F9 | Восстановление автоматического масштабирования для всех диаграмм
F10 | Активизация панели данных
Ctrl+Shift+F6 | Инвертирование забракования геопотенциальной высоты на выбранном уровне или в слое
F11 | Вывод на панель диаграмм диаграмму TH и ее активизация
F12 | Вывод на панель диаграмм диаграмму DV и ее активизация
Alt+F12 | Вывод на панель диаграмм диаграмму XY и ее активизация

4.5.2. Навигация по панелям

Перемещение между панелями осуществляется с помощью клавиши табуляции ↹ или, для перемещения в обратном порядке, клавиш Shift+↹. Когда соответствующая панель становится активной, она реагирует на ввод с клавиатуры. Индикация активности соответствующей панели осуществляется следующим образом:

1. Для панели инструментов – цветом панели. Неактивная панель закрашивается белым, активная – серым цветом;

2. Для панели данных – цветом шрифта и фона заголовка: шрифт белого цвета на темно-синем фоне у активной и темно-синего цвета на белом фоне у неактивной панели.

3. Для панели диаграмм – стилем шрифта ярлыков вкладок: у активной панели он полужирный.

4.5.3. Панель инструментов

Когда активна панель инструментов, дальнейшее нажатие клавиши табуляции ↹ или клавиш Shift+↹ приводит к навигации между органами панели инструментов. Когда активен список выбора режима правки (при этом изменяется цвет фона выбранной строки), выбор режима можно осуществить, выбирая нужную строку клавишами управления курсором. Когда активна одна из кнопок панели инструментов (у активной кнопки текст заключен в рамку), для выполнения связанного с ней действия[2] вместо нажатия левой кнопки мыши можно нажать клавишу ввода ↵ (Enter) на клавиатуре, а для перехода к соседним кнопкам можно также использовать кнопки управления курсором.

Действия кнопок «Урвн(F2)» …«W(F6)» установок признаков забракования может быть модифицировано при помощи клавиш Ctrl и Shift клавиатуры. Если при нажатии левой кнопкой мыши одной из указанных кнопок или соответствующих клавиш F2..F6 на клавиатуре одновременно нажать клавишу Ctrl, установка признака забракования соответствующей метеовеличины для выбранного в таблице данных уровня или слоя будет отменена, независимо от текущих установок списка выбора режима. Наоборот, если вместо клавиши Ctrl при этом нажать клавишу Shift, признак забракования будет установлен. Наконец, одновременное нажатие клавиш Ctrl и Shift вместе с нажатием указанных кнопок переключит установки признака забракования.

Пример: если в ситуации, показанной на рис.3, нажать кнопку «±H(F5)» или клавишу F5, то признак забракования будет отменен для геопотенциальной высоты на уровнях с 1170 по 1348 с, но при этом установлен для уровней с 1131 по 1162 с. Если же при этом была бы нажата клавиша Ctrl, то нажатие кнопки кнопку «±H(F5)» или клавиши F5 отменяет установку признака забракования для геопотенциальной высоты и для уровней с 1179 по 1348 секунду забракование геопотенциальной высоты было бы отменено, как показано на рис. 7.

Рисунок 5. Результат нажатия кнопки «±H(F5)» при нажатой клавише Ctrl.

4.5.4. Панель данных

Выбрать нужный уровень (строку) в таблице данных можно и с использованием клавиш управления курсором ↓ (вниз) и ↑(вверх). Клавиши PageUp и PageDn (на некоторых клавиатурах – соответственно PgUp и PgDn) позволяют пролистывать таблицу соответственно вверх и вниз на количество строк, помещающееся в окне таблицы, клавиши Home и End - в начало и конец таблицы. Если при использовании указанных клавиш для пролистывания таблицы данных одновременно удерживать клавишу Shift, можно выделить несколько уровней одновременно, т.е. слой, для правки признаков забракования.

Клавиши → и ← позволяют прокручивать таблицу данных вправо и влево, если часть колонок не помещается в окне панели, чтобы отобразить в окне панели требуемые колонки.

4.5.5. Панель диаграмм

Для перехода к нужной вкладке с использованием клавиатуры необходимо последовательно набрать комбинацию клавиш Ctrl+↹ (Ctrl+Shift+↹) для пролистывания в обратном порядке) на клавиатуре нужное количество раз.

[1] В отличие от кода КН-04 TEMP при передаче аэрологических данных в коде BUFR особые точки по направлению и скорости ветра не разделяются.

[2] Например, для кнопки «Отмена» - завершения сеанса проверки данных с отменой формирования и отправки сообщения BUFR.


UABUFRCheck.doc/05.04.2017 ПО UABUFR: Проверка данных выпуска при подготовке данных в коде BUFR

1