Ниже описана работа с программой при использовании типовых, рекомендуемых настроек

1. Подготовка к отправке сообщений в коде BUFR

По достижению высоты 100 гПа или завершении выпуска и готовности соответствующих данных завершите обработку, контроль данных и, при необходимости, правку особых точек и текстов соответствующих телеграмм. При использовании комплексов АВК - АРМ Аэролога – при подготовке сообщения с данными от уровня станции до 100 гПа после завершения контроля телеграмм необходимо также выбрать в ПО ОРД пункт меню «Выпуск/Сохранить» для сохранения файлов edt с результатами обработки данных радиозондирования с высоким вертикальным разрешением.

Убедитесь, что сформированы все файлы с данными, необходимые для формирования сообщения с данными радиозондирования в коде BUFR для используемого комплекса радиозондирования.

При редактировании данных из файлов, используемых для включения в сообщение в коде BUFR, необходимо особо тщательно следить за сохранением формата данных соответствующих файлов.

Запустите программу UABUFR с помощью ярлыка на Рабочем столе

Рисунок 1. Ярлык программы UABUFR на Рабочем столе

или переключитесь на ее окно, если программа уже запущена.

Если текущий выпуск не загружен автоматически при запуске программы, нажмите кнопку «Выпуск» для выбора соответствующего файла для текущего или требуемого выпуска (для комплексов АВК ЭОЛ, МАРЛ, Вектор – INFO, АВК АРМ Аэролога – STG, АВК «Аэрология» – KN):

Рисунок 2. Диалог выбора выпуска (для данных АП МАРЛ).

По умолчанию в диалоге выбора отображаются файлы за текущие и предыдущие сутки. При необходимости передать данные предыдущих выпусков (например, после внесения исправлений) — выберите в поле «Тип файлов» значение «Все выпуски» и затем - нужный выпуск.

После загрузки и проверки данных справа от кнопки «Выпуск» должны отобразиться имя выбранного файла, а также дата и срок выбранного выпуска. Если данные этого выпуска уже были ранее закодированы в BUFR, будут загружена сохраненная информация о загруженном выпуске.

Рисунок 3. Главное окно программы

Введите, подтвердите или откорректируйте дополнительную информацию о выпуске, руководствуясь приведенной ниже таблицей

Поле

Информация

Комментарии

№

Порядковый номер выпуска в году

Можно вводить число непосредственно в поле ввода, использовать клавиши управления курсором ↓ (вниз) и ↑(вверх), а также путем нажатия мышью кнопок со стрелками справа от поля ввода

Повторный

Отметка, является ли выпуск повторным

Если повторные выпуски не запрещены, установите отметку «Да» для повторного выпуска, в противном случае – «Нет».

Если выпуск был повторным, его порядковый выпуск не увеличивается

Старший смены

Инициалы (ФИО) старшего смены, производившей радиозондирование

Выберите в выпадающем списке нужную строчку или введите вручную[1] фамилию, имя и отчество старшего смены (тремя прописными символами русского алфавита)

Радиозонд/система

Тип радиозонда/системы радиозондирования

Выберите в выпадающем списке нужную строчку

№ р/з

Серийный номер радиозонда

При наличии номеров датчиков, серийный номер радиозонда дополняется номерами датчиков температуры (влажности) через символ «/», например:

'2242177/60469' – кодирование серийного номера АК2-02, где 2242177 – серийный номер радиоблока, а 60469 – номер блока датчиков температуры и влажности.

Количество символов не должно превышать 20

Оболочка

Тип, производитель и масса (в граммах) используемой оболочки

Выберите в выпадающем списке нужную строчку

Газ

Газ, используемый для наполнения оболочки

Выберите в выпадающем списке строчку «Н2», если используется водород, и «Не», если используется гелий

Под.сила, кг

Подъемная сила, определяемая массой груза, удерживающего наполненную газом оболочку (норма наполнения оболочки) в кг с точностью до 0.01 кг

Можно вводить число непосредственно в поле ввода, использовать клавиши управления курсором ↓ (вниз) и ↑(вверх), а также путем нажатия мышью кнопок со стрелками справа от поля ввода

Длина подвеса, м

Длина подвеса радиозонда к оболочке в м с точностью до 0.1 м

Можно вводить число непосредственно в поле ввода, использовать клавиши управления курсором ↓ (вниз) и ↑(вверх), а также путем нажатия мышью кнопок со стрелками справа от поля ввода

Прекращение

Причина прекращения выпуска

Выберите в выпадающем списке нужную строчку. При формировании и отправке сообщения с данными от уровня станции до 100 гПа вводить информация о причине прекращения выпуска не требуется

Пока не будет введена или подтверждена вся требуемая информация, формирование и отправка сообщений в коде BUFR и части В телеграммы КН-04 невозможна – соответствующие кнопки заблокированы. Для отображения полей, требующих ввода или подтверждения, используется шрифт красного цвета. Для отображения подтвержденных полей используется шрифт черного или синего (если значение поля было изменено) цвета.

Явного ввода значений требуют поля «Старший смены», «№ р/з» «Прекращение», являющиеся по умолчанию пустыми. Часть информации, редко изменяющаяся от выпуска к выпуску, как например – газ, используемый для наполнения оболочки, или прогнозируемый номер выпуска, сохраняется после завершения программы и вновь загружается и отображается в соответствующих полях при ее запуске. Чтобы уменьшить возможность ошибок, каждое такое поле требует подтверждения, для чего достаточно просто перейти к соответствующему полю с помощью клавиатуры или мыши, при необходимости изменяя данные. Перемещение между полями осуществляется с помощью клавиши табуляции ↹ или, для перемещения в обратном порядке, клавиш Shift+↹. Перейти к тому или иному полю можно также с помощью мыши или горячих клавиш.

Нажмите кнопку «BUFRI» для загрузки данных выпуска, формирования сообщения в коде BUFR с данными от уровня земли до высоты 100 гПа и его отправки. После завершения выпуска нажмите кнопку «BUFRII» для загрузки данных выпуска, формирования сообщения в коде BUFR с данными от уровня земли до конечной высоты обработки и его отправки. Особые случаи при загрузке, связанные с отсутствием отдельных файлов, ошибок их чтения или разночтениях в информации описаны в разделе «Особые ситуации».

Рисунок 4. Ввод и подтверждение информации

После загрузки данных выпуска открывается окно «Проверка данных». Проверьте загруженные данные выпуска и, при необходимости, исключите недостоверные данные из формируемого сообщения BUFR. Работа с окном «Проверка данных» подробно описана в разделе «Проверка данных выпуска».

После завершения проверки данных формируется сообщение в коде BUFR, файл с которым сохраняется на диске и отправляется в каналы связи согласно настройкам программы. Если по каким-либо причинам отправка не удалась или была прервана, после устранения причин сбоя отправки снова нажмите нужную кнопку «BUFRI» или «BUFRII». Программа выдаст сообщение

Рисунок 5. Запрос при повторной отправке BUFR

Нажмите кнопку «Использовать существующий», чтобы отправить ранее созданное сообщение BUFR.

Если же по каким-либо причинам нужно заново сформировать и отправить соответствующее сообщение BUFR (например, внесены какие-либо изменения в результаты обработки, такие как выбор особых точек, или дополнительную информацию о выпуске) нажмите кнопку «Создать новый», в этом случае после завершения проверки данных файл с предыдущим сообщением BUFR будет перезаписан новым.

Для отказа от продолжения нажмите кнопку «Отменить отправку BUFR».

При внесении исправлений в данные выпуска или в дополнительную информацию уже после отправки одного или обоих сообщений BUFR, новое сообщение в коде BUFR нужно отправлять с применением указателя CCx: ССА для первого, ССB, CCC и т.д. для последующих исправлений. Если дополнительная информация о выпуске изменена уже после отправки одного или обоих сообщений BUFR, надпись у рамки «BBB» может отображаться шрифтом красного цвета, указывая на необходимость использования указателя ССx. Установите отметки «+» и «CCx» внутри рамки «BBB» и выберите необходимую букву для указателя CCx в зависимости от порядкового номера исправления. Нажмите нужную кнопку «BUFRI» или «BUFRII» для формирования и отправки исправленного сообщения.

Рисунок 6. Отправка сообщения с исправлениями

Если настройками программы не предусмотрена отправка сообщения BUFR в каналы связи, после сохранения на диске файла со сформированным сообщением выдается соответствующее подтверждение:

Рисунок 7. Подтверждение сохранения файла с сообщением BUFR

2. Отправка сообщений в традиционных кодах

Для подготовки и отправки сообщений с частями A, B, C и D аэрологической телеграммы КН‑04, данными в приземном слое «ПРИЗЕМНЫЙ СЛОЙ» и о среднем ветре «СЛОЙ» предварительно убедитесь, что соответствующие сообщения уже созданы соответствующим программным обеспечением кодирования, и в них, при необходимости, внесены все требуемые изменения, а соответствующие файлы сохранены.

Запустите, при необходимости, программу UABUFR и выберите файл искомого выпуска, текущего или требуемого. Кнопка «TTBB» заблокирована до тех пор, пока не подтверждено поле «Радиозонд/система», как указано выше. Для отправки соответствующего сообщения нажмите кнопку «TTAA», «TTBB», «TTCC», «TTDD», «ПРИЗ» или «СЛОЙ» по мере готовности файлов с соответствующими сообщениями. Если необходимо включить указатель CCx в заголовок отправляемого сообщения, установите отметки «+» и «CCx» внутри рамки «BBB» и выберите необходимую букву для указателя CCx в зависимости от порядкового номера исправления: A, B, C и так далее.

После нажатия нужной кнопки и загрузки файла с соответствующим сообщением открывается окно «Телеграмма:ХХХХ», где ХХХХ – условное обозначение соответствующей телеграммы, например: TTAA.

Рисунок 8. Окно просмотра/редактирования текстовой телеграммы с телеграммой «ПРИЗЕМНЫЙ СЛОЙ»

В окне отображается сформированный текст соответствующей телеграммы с необходимыми заголовками, готовый к отправке. После просмотра текста сформированного бюллетеня нажмите кнопку «Отправить». После этого сообщение отправляется в каналы связи согласно настройкам программы и сохраняется в файл на диске.

3. Отправка сообщений каналы связи

Отправка в каналы сообщений в коде BUFR и традиционных текстовые телеграмм принципиально ничем не отличается, только при использовании e-mail традиционные телеграммы передаются в тексте сообщения электронной почты, а сообщения в коде BUFR отправляются в виде вложений.

3.1. Отправка по электронной почте с использованием почтовых программ

Поскольку в качестве почтовых программ могут использоваться любые программы, поддерживающие стандартный интерфейс Windows Simple MAPI: Outlook Express, Microsoft Office Outlook, Windows Mail, TheBat!, здесь приводятся самые общие сведения и примеры использования почтовой программы TheBat! – конкретные приемы работы определяются почтовой программой, используемой на АЭ.

После нажатия кнопки «Отправить» в окне просмотра соответствующей текстовой телеграммы или кнопки «ОК» в окне «Проверка данных» соответствующее окно закрывается, программа вызывает окно создания сообщения электронной почты используемой почтовой программы:

Рисунок 9. Окно создания сообщения электронной почты с сообщением в коде BUFR с данными до уровня 100 гПа

Поля с адресатами и темой сообщения заполняются автоматически. При отправке текстовой телеграммы ее текст автоматически вставляется в сообщение, при отправке сообщения BUFR оно автоматически прикрепляется к письму.

Отправьте сформированное сообщение согласно руководству используемой почтовой программы - при использовании почтовой программы TheBat! для отправки сообщения нужно выбрать пункт меню «Письмо/Отправить сейчас».

Рисунок 10. Окно создания сообщения электронной почты с телеграммой «ПРИЗЕМНЫЙ СЛОЙ»

3.2. Отправка по электронной почте с использованием встроенного почтового клиента

После нажатия кнопки «Отправить» в окне просмотра соответствующей текстовой телеграммы или кнопки «ОК» в окне «Проверка данных» это окно закрывается, а после этого выводится диалоговое окно с информацией об ходе отправки:

Рисунок 11. Окно с информацией об отправке электронной почты

В заголовке окна отображается заголовок отправляемого сообщения электронной почты, а в самом окне - служебная или диагностическая информация о состоянии отправки. После успешного завершения отправки в диалоговом окне отображается надпись: «Сообщение отправлено»:

Рисунок 12. Подтверждение успешной отправки сообщения электронной почты с телеграммой ТТВВ

3.3. Загрузка на ФТП-сервер по протоколу ВМО

После нажатия кнопки «Отправить» в окне просмотра соответствующей текстовой телеграммы или кнопки «ОК» в окне «Проверка данных» это окно закрывается, а после этого выводится диалоговое окно с информацией о ходе загрузки:

Рисунок 13. Окно с информацией о загрузке на ФТП-сервер

При загрузке текстовой телеграммы в заголовке окна отображается условное обозначение отправляемой телеграммы (TTAA…TTDD, PRIZ, SLOY) и название создаваемого на сервере файла. При загрузке сообщения BUFR в заголовке окна отображается название загружаемого файла и название создаваемого на сервере файла. В окне отображается служебная информация о ходе загрузки, а в случае ошибок – диагностическая информация об ошибках. После успешного завершения отправки в диалоговом окне отображается надпись: «Загрузка завершена успешно»:

Рисунок 14. Подтверждение успешной загрузки сообщения BUFR с данными до 100 гПа на ФТП-сервер

3.4. Копирование в заданную папку

При соответствующей настройке программы вместо отправки в каналы связи доступно копирование файлов со сформированными сообщениями по заданному пути. После нажатия кнопки «Отправить» в окне просмотра соответствующей текстовой телеграммы или кнопки «ОК» в окне «Проверка данных» соответствующее окно закрывается, а файл с сообщением копируется в заданную папку:

Рисунок 15. Подтверждение копирования сообщения BUFR в заданную папку

Рисунок 16. Подтверждение копирования сообщения ТТАА в заданную папку

3.5. Копирование в буфер обмена

При соответствующей настройке программы для текстовых телеграмм вместо отправки в каналы связи доступно копирование сформированных сообщений в буфер обмена.

После нажатия кнопки «Отправить» в окне просмотра соответствующей текстовой телеграммы окно закрывается, а содержащийся в нем текст копируется в буфер обмена Windows:

Рисунок 17. Подтверждение сообщения ТТАА в буфер обмена Windows

Скопированное в буфер сообщение можно использовать, например, при отправке сообщений с использованием Web-интерфейса.

[1] Ручной ввод может быть заблокирован в настройках


UABUFRInst.docx/28.03.2017 ПО UABUFR: Рабочая инструкция оператора

1