1. Назначение и область применения

Программное обеспечение (ПО) UABUFR предназначено для использования на аэрологической сети Росгидромета для кодирования и передачи в каналы связи результатов радиозондирования в коде BUFR из выходных файлов, создаваемых программным обеспечением АРВК, для установленных до 2013 г. МАРЛ-А, Вектор-М, а также модернизированных до 2017 г. АВК.

ПО UABUFR может также использоваться для передачи в каналы связи результатов радиозондирования текстовых сообщений в традиционных кодах (КН-04, СЛОЙ, ПРИЗЕМНЫЙ СЛОЙ), формируемых штатным ПО АРВК.

Использование ПО UABUFR на аэрологических станциях стран-членов Межгосударственного совета по гидрометеорологии СНГ регулируется двусторонними соглашениями. Использование программы UABUFR для оперативной передачи в коде BUFR результатов радиозондирования аэрологических комплексов, для которых оно не предназначено, без согласования с ФГБУ «ЦАО» является неправомерным и влечет за собой также ответственность за использование нелицензионного программного обеспечения. Программа распространяется через Интернет-сайт НТЦР ФГБУ «ЦАО» http://cao-ntcr.mipt.ru/bufr, запрещается внесение любых изменений в программный код, за исключением прямо разрешенных законодательством.

1.1. Общие сведения о коде BUFR

Кодовая форма, или код, FM 94 BUFR (Binary Universal Form for Representation meteorological data - двоичная универсальная форма для представления метеорологических данных, произносится по-русски как «б-а-ф-р») является одним из видов таблично-ориентированных кодовых форм (ТОКФ), предложенных Всемирной метеорологической организацией (ВМО) как универсальный гибкий расширяемый формат для обмена данными всех видов гидрометеорологических наблюдений. Они рассматриваются ВМО как единственный формат, которые необходим для кодирования данных наблюдений и рекомендуется для всех существующих и будущих областей деятельности ВМО.

Кодовая форма, или код, BUFR представляет компактный способ передачи данных за счет двоичного представления данных и дополнительно предлагает возможность сжатия данных, однако является машинно-ориентированной – как кодирование, так и декодирование возможно только с использованием компьютера при наличии соответствующего программного обеспечения. ВМО рекомендует использовать BUFR во всех существующих и вновь разрабатываемых автоматизированных системах наблюдений.

Второй вид ТОКФ - буквенно-цифровая кодовая форма CREX FM 95 CREX (Character form for Representation and EXchange of data – символьная форма для представления и обмена данными) имеет ограниченное применение и в Росгидромете не используется. CREX предназначен для восприятия человеком и допускает ручное кодирование. CREX рекомендуется применять для неавтоматизированных наблюдений, а также в случае отсутствия современных каналов связи, способных передавать двоичные данные

В настоящее время все страны-члены ВМО планомерно заменяют на ТОКФ (преимущественно, на BUFR) все ранее используемые традиционные коды, имеющие многочисленные ограничения, ограничивающие прогресс в обмене и распространении метеорологических данных. Потребители аэрологической информации во всем мире проявляют особый интерес к использованию BUFR для передачи данных радиозондирования, заинтересованные в использовании максимально полного объема аэрологической информации, получаемой с использованием современных автоматизированных систем радиозондирования.

В отличие от традиционного кода КН-04 TEMП (FM 35), изначально ориентированного на передачу данных радиозондирования при ручной обработке, BUFR позволяет передавать данные с результатами обработки на всех имеющихся уровнях (с высоким вертикальным разрешением) с привязкой к полетному времени и географическим координатам радиозонда и, как следствие, существенно увеличить точность представления пространственного и временного распределения метеорологических величин в атмосфере. Хотя при использовании BUFR сохраняется и возможность передавать данные на уровнях особых точек и стандартных изобарических поверхностей, она оставлена лишь для обратной совместимости на переходной период (в дальнейшем данные на уровнях стандартных изобарических поверхностей могут восстанавливаться заинтересованными потребителями самостоятельно из данных высокого вертикального разрешения). Соответственно, должны отойти в прошлое многочисленные проблемы, связанные с кодированием результатов радиозондирования современных систем радиозондирования с использованием традиционного кода: ограниченная точность представления данных и неоднозначность выбора особых точек. Кроме того, BUFR позволяет передавать дополнительную информацию о самом выпуске, такую, например, как подъемную силу.

На сети Росгидромета данные радиозондирования в коде BUFR с 2011 г. уже передают АЭ Долгопрудный, Мурманск и Нижний Новгород, используя предшествующие версии ПО кодирования (EOL2BUFR, EDT2BUFR), разработанное в НТЦР ЦАО. Это же ПО используется в Белгидромете и Казгидромете. В 2012 г. было успешно проведено тестирование ввода и прохождения через узлы АСПД данных наблюдений в коде BUFR. Дальнейшее распространение в Росгидромете использования BUFR для передачи аэрологических данных сдерживалось тем, что в течение нескольких лет ВМО продолжала совершенствовать представление данных радиозондирования в коде BUFR – последние изменения к правилам передачи данных TEMP, TEMP SHIP и TEMP MOBIL в ТОКФ вступили в силу в ноябре 2016 г. За это время отечественные потребители и разработчики технологий использования аэрологических данных в коде BUFR (Гидрометцентр РФ, ВНИИГМИ-МЦД, НПО МэпМейкер) освоили их декодирование и использование и подготовились к его массовому внедрению.

С 1.07.2017 г. передача аэрологических данных в коде BUFR c аэрологической сети Росгидромета регламентируется «Порядком передачи результатов радиозондирования с аэрологической сети Росгидромета в коде FM 94 BUFR», введенных в действие Приказом Росгидромета №___ от __.04.2017 г.

Несмотря на то, что внутренняя организация и формат представления данных в коде BUFR сравнительно сложны и требуют значительных усилий для освоения, ПО UABUFR спроектировано таким образом, чтобы полностью оградить наблюдателя от необходимости их изучения.

Для обеспечения контроля и визуализации результатов радиозондирования, оперативно передаваемых в каналы связи в коде BUFR, на аэрологических станциях и в отделах/группах аэрологии УГМС, НТЦР ЦАО на базе ПО «АРХИВ» АРМ Аэролога ФГУП «КОМЕТ» разработано ПО «Архив BUFR». Домашняя страница программы на сайте НТЦР ЦАО - http://cao-rhms.ru/update/bufr/bufrde.htm.

Пользователи, которые интересуются дополнительной информацией о ТОКФ и их использовании для кодирования аэрологических данных могут найти ее в Руководстве ВМО по ТОКФ, русская версия которого размещена на сайте ВМО по адресу: http://www.wmo.int/pages/prog/www/WMOCodes/Guides/BUFRCREXPreface_ru.html и на сайте виртуальной лаборатории Росгидромета «Методы и средства гидрометеорологических измерений» по адресу:

http://tech.meteorf.ru/index.php?option=com_content&view=article&id=30:bufr&catid=12&Itemid=107. Однако эта информация не является необходимой для успешного освоения и использования ПО UABUFR.

С практической точки зрения основные отличия от традиционной практики при передаче результатов радиозондирования в коде BUFR:

- Необходимость использования дополнительного программного обеспечения как для кодирования данных (ПО UABUFR), так и для просмотра закодированного сообщения (ПО «Архив BUFR»);

- Необходимость ввода дополнительной информации о выпуске;

- В отличие от передачи данных зондирования в коде КН-04, данные зондирования в коде BUFR передаются двумя сообщениями (телеграммами): первым по мере готовности результатов передается сообщение с данными от уровня станции до уровня 100 гПа, а по завершении выпуска передается второе сообщение с данными всего подъема от уровня станции до конечной высоты обработки. Таким образом, потребители избавлены от необходимости объединять несколько телеграмм с разными частями КН-04, чтобы восстановить весь выпуск.

2. Системные требования

Операционная система – от Windows 98 до Windows 10, монитор с разрешением от 800 х 600 с поддержкой TrueColor (65536 цветов), до 10 Мбайт на жестком диске (с ПО для освоения программы кодирования и с демонстрационными примерами).

3. Входные данные

Для кодирования результатов радиозондирования в коде BUFR используются выходные файлы, создаваемые ПО обработки комплексов АРВК:

· АВК-АП «ЭОЛ» и Вектор-М с обработкой АП «ЭОЛ»: файлы «Начальные данные» INFO, «Таблица результатов радиозондирования» TAE3, «Приземный слой» GLAYER, вспомогательные файлы RAWDATA и SPoints;

· АВК-АРМ Аэролога: файлы «Начальные данные» STG и «Результаты обработки» EDT;

· МАРЛ-А, Вектор-М и АВК с модернизированным АП «ЭОЛ» с обработкой ПО «Телеграмма»: файлы с данными высокого разрешения PROF, «Начальные данные» INFO, «Таблица результатов радиозондирования» TAE3(TAE03), «Приземный слой» GROUND, вспомогательные файлы RAW и SP.

4. Начало работы

Ознакомьтесь с рекомендациями по освоению ПО UABUFR в документе UABUFRTrain.doc.


UABUFRIntro.doc/01.04.2017 ПО UABUFR: Общие сведения о программе

2