1. Установка программы на ПЭВМ

Архив uabufrinst.zip с программой, обеспечивающей установку ПО UABUFR на диск ПЭВМ, размещен на сайте НТЦР ФГБУ «ЦАО» на страницы http://cao-ntcr.mipt.ru/bufr «Передача аэрологических данных в коде BUFR» - прямая ссылка для загрузки последней версии http://cao-ntcr.mipt.ru/bufr/uabufrinst.zip.

Для установки ПО UABUFR на диск ПЭВМ необходимо извлечь из архива uabufrinst.zip программу uabufrinst.exe и запустить ее на исполнение. При работе в Windows версии Vista и более поздними может потребоваться подтверждение запуска программы uabufrinst.exe и запускаемой ею вспомогательной служебной программы setuplink.exe.

Рисунок 1. Окно программы установки ПО UABUFR

После запуска программы установки необходимо нажать кнопку «Извлечь файлы», дождаться сообщения «Извлечено .. файлов»[1] и нажать кнопку «Закрыть»:

вв

Программа установки записывает файлы ПО UABUFR в папку C:\UACODER и создает ярлык для запуска исполняемого файл uabufr.exe на Рабочем столе Windows:

Рисунок 3. Ярлык программы UABUFR на Рабочем столе

Исполняемый файл uabufr.exe и шаблоны файлов конфигурации записываются в папку C:\UACODER\bin, документация и резервные копии шаблонов файлов конфигурации – в папку C:\UACODER\doc.

При необходимости (например, в случае непреднамеренного удаления или изменения какого-либо файла), исходные файлы можно восстановить, повторно запустив программу uabufrinst.exe. Если запустить программу uabufrinst.exe с ключом verbose, можно выбрать нужные файлы в списке файлов с тем, чтобы исключить утерю настроек, уже внесенных в файлы конфигурации, и определить действия при извлечении файлов, которые уже находятся на жестком диске.

Рисунок 4. Выборочное извлечение из архива файлов ПО

Рисунок 5. Просмотра архива uabufrinst.exe с помощью программы WinR AR

Программа установки и само ПО UABUFR не создает никаких записей в реестре Windows, для удаления ПО достаточно удалить папку C:\UACODER и ярлык uabufr.exe с Рабочего стола Windows.

Для обеспечения возможности отправки сообщений по электронной почте встроенными средствами ПО UABUFR при подключении к серверу в режиме SSL/TLS может потребоваться также установка библиотек dll (libeay32.dll и ssleay32.dll) пакета OpenSSL (www.openssl.org), которые нужно скопировать в рабочую папку программы или системную папку Windows (в зависимости от версии Windows - c:\Windows\System32 или c:\Windows\System).

При необходимости ПО UABUFR может быть размещено в произвольной папке - программа uabufrinst.exe представляет собой самораспаковывающейся архив самого распространенного формата ZIP, из которого можно извлекать файлы, используя сторонние программы работы с архивами такие как WinRAR, 7-ZIP, Total Commander. В этом случае ярлык на Рабочем столе Windows необходимо создать вручную.

2. Настройка ПО UABUFR

2.1. Общие положения

Перед использованием программы uabufr.exe необходимо задать параметры ее конфигурации в файлах конфигурации, записываемых на диск при установке ПО UABUFR в папку C:\UACODER\bin (шаблоны файлов конфигурации в папке C:\UACODER\doc изменению не подлежат, они могут использоваться как образец при редактировании файлов конфигурации).

По умолчанию, файлы конфигурации должны находиться в той же папке, что и, однако это можно изменить с помощью параметров командой строки, как описано ниже. Назначение файлов конфигурации описано в табл. 1. За исключением файла ASCVAR.CNF, который создается программой автоматически, наличие остальных файлов конфигурации обязательно. Если хотя бы один из них отсутствует, или в нем не заданы или заданы некорректно обязательные настройки, программа при запуске выдает соответствующее предупреждение и прекращает работу. Настройки загружаются из файлов конфигурации только при запуске программы. Если изменения были внесены после того, как программа уже была запущена, необходимо ее закрыть и запустить заново, чтобы внесенные изменения вступили в силу.

После внесения необходимых изменений в файлы конфигурации и проверки работы файлы настройки следует отправить в НТЦР ЦАО для проверки на адрес aero@cao-btcr.mipt.ru. После подтверждения НТЦР ЦАО рекомендуется установить для файлов конфигурации атрибут «только чтение» (read-only), скопировать файлы в безопасное место (например, на съемном носителе) или распечатать.

Рисунок 6. Изменение атрибута «только чтение» для файла конфигурации

Таблица 1. Назначение файлов конфигурации

Файл | Назначение
ARVK2BFR.CNF | Общие настройки программы и ее интерфейса
ASCVAR.CNF | Создается и обновляется автоматически при выходе из программы и предназначен для сохранения переменной информации, вводимой оператором или обновляемой автоматически во время работы программы
ASPD.CNF | Настройки параметров формирования и отправки сообщений в каналы связи по электронной почте или ФТП (отдельные разделы не требуются, если соответствующие способы отправки в каналы не используются)
BUFRCODES.CNF | Настройки, необходимые для формирования сообщений в коде BUFR, в том числе используемые кодовые таблицы. Файл снабжен электронной подписью BUFRCODES.CRC и не подлежит изменениям на АЭ. При необходимости он обновляется и распространяется централизованно НТЦР ЦАО
STATION.CNF | Настройки параметров АЭ и используемой системы радиозондирования

2.2. Формат файлов конфигурации

Файлы конфигурации, используемые ПО UABUFR, имеют стандартный формат файлов настроек ini, используемых Microsoft Windows. Это текстовые файлы, для редактирования которых могут использоваться любые текстовые редакторы, например – стандартный Блокнот Windows. Информация в файлах настроек логически группируется в разделы, каждый из которых начинается оператором заголовка, заключенным в квадратные скобки. В строках, следующих за заголовком вплоть до следующего заголовка или конца файла, содержится информация о значениях параметров, относящихся к данному разделу, в форме:

<Параметр>=<Значение>

Строки, начинающиеся с символа двоеточия, являются комментарием, они предназначены исключительно для пояснения назначения параметров и примеров их применения и не оказывают никакого влияния на работу программы.

Например, в следующий фрагменте файла конфигурации STATION.CNF

;=====================================================================

;информация о станции:Координаты и индексный номер и т.д.

[Station]

;!N:Индексный номер АЭ

StationInd=27612

в разделе [Station] параметру StationInd, соответствующему индексному номеру станции, задается значение 27612.

В приложении приведены шаблоны файлов конфигурации, содержащие подробные комментарии. В строках комментариев, предшествующих строкам задания параметров, в первой строке с комментарием признака комментария ; указывается признак типа параметра

  • N: – целое число, например – индекс системы радиозондирования
  • D: – вещественное число, например – широта станции. В качестве десятичного разделителя должна использоваться точка
  • T: – текстовый параметр, например – версия ПО

· L: – логический параметр, который может принимать значения 0 или 1. 0 означает, что соответствующая опция отключена, 1 – включена. например – наличие РПУ.

После признака комментария ; перед признаком типа параметра может присутствовать символ!, что означает, что следующий за ним параметр обязательный и требует явного задания. Например, в шаблоне файла конфигурации STATION.CNF в папке C:\UACODER\bin строка с параметром из приведенного выше фрагмента выглядит как

StationInd=

Соответственно, при настройке ПО UABUFR после символа следует = внести индексный номер АЭ.

Параметры, которые не требуют явного задания или для которых предусмотрены значения по умолчанию, предваряются символом комментария ;. Например, в следующий фрагменте раздела [OPTIONS] файла конфигурации ARVK2BFR.CNF

;L:Допускает возможность повторных выпусков. Если 0, выбор "Повторный выпуск" недоступен

;Repeated=0

параметр Repeated принимает заданное по умолчанию значение 0, т.е. возможность повторных выпусков не предусмотрена. Если же повторные выпуски на АЭ возможны, то следует удалить из строки параметра признак комментария и явно задать значение 1:

Repeated=1

В результате после загрузки программы оператору при формировании сообщения BUFR станет доступна возможность указания, что выпуск является повторным.

В заголовках сообщений для указания пробелов и непечатных символов можно указывать двузначные шестнадцатеричные коды, предваряемые префиксом #$. Например, символам возврата строки, перевода каретки и пробела соответствуют сочетания #$0D, #$0A и #$20. Для указания даты и времени можно в фигурных скобках указывать спецификаторы формата представления даты: y,m,d,h,n,s для года, месяца, дня, часа, минуты и секунды. Рекомендуется при наличии такой возможности включать дату и срок в темы почтовых сообщений, в особенности бинарных, чтобы наблюдателям легче было идентифицировать сообщения во внешнем почтовом клиенте, чтобы исключить непреднамеренную отправку сообщения с данными, не соответствующими текущему сроку. Например, шаблону заголовка TTAA:{yymm-dd:hh} для срока 21.2.2013-12 ВСВ будет соответствовать заголовок TTAA:1302-21:12.

Символы <BBB> в угловых скобках обозначают место для подстановки соответственно указателя BBB и индексного номера АЭ в заголовках метеорологических и почтовых сообщений.

Кроме символов <BBB> для обозначения указателя BBB могут использоваться символы:

<BBX> - в этом случае указатель BBB подставляется в выходное сообщение в виде RTD при выборе оператором RRx и COR при выборе оператором CCx

<BBR> - в этом случае указатель BBB подставляется в выходное сообщение в виде РРx при выборе оператором RRx и ЦЦx при выборе оператором CCx, где x - меняющийся от А до Х знак латинского алфавита, представленный идентичной по коду русской буквой

<BRX> - в этом случае указатель BBB подставляется в выходное сообщение в виде РТД при выборе оператором RRx и ЦОР при выборе оператором CCx.

Порядок использования указателя BBB определяется местным центром сбора данных.

2.3. Рекомендации по настройке файлов конфигурации

Ниже для ссылок на параметры будет использоваться форма Раздел/Параметр.

В первую очередь необходимо задать все обязательные настройки в файле STATION.CNF: координаты и индекс станции и используемой системы зондирования. При задании параметров ARVK/single, ARVK/ARVKnum, ARVK/AntennaHeightAbove и ARVK/SoftVer следует руководствоваться Приложением 1 к «Порядку передачи результатов радиозондирования с аэрологической сети Росгидромета в коде FM 94 BUFR».

Таблица 2. Определения индексов системы зондирования, используемых для задания параметра ARVK/ARVK

ARVK= | Определение
0 | АВК – АП «ЭОЛ»
1 | АВК – модернизированный АП «ЭОЛ» с обработкой ПО «Телеграмма»
2 | АВК – модернизированный АП «ЭОЛ» с обработкой ПО «Телеграмма» без выдачи файлов prof
3 | МАРЛ-А с обработкой ПО «Телеграмма»
4 | МАРЛ-А с обработкой ПО «Телеграмма» без выдачи файлов prof
5 | ВЕКТОР-М с обработкой ПО «Телеграмма»
6 | ВЕКТОР-М с обработкой ПО «Телеграмма» без выдачи файлов prof
7 | ВЕКТОР-М с обработкой АП «ЭОЛ»
8 | АВК – АРМ Аэролога

Версию АВК-АП «ЭОЛ» можно узнать, вызвав пункт меню «Помощь/О комплексе», для АВК-АРМ Аэролога версия ПО указывается в последней строке в файле RES с результатами выпуска. Для МАРЛ-А версии ПО выводятся на соответствующей вкладке программы Settings.exe, эта же программа выводит информацию по поправкам по углу места и азимута. Для Вектор-М версия управляющей программы выводится прямо в заголовке ее окна, информацию по поправкам по углу места и азимута можно проверить в диалоге настройки параметров, вызываемом кнопкой «Настройка». Насколько известно, не существует ПО, поставляемое с Вектор-М, не позволяет определить версию программы «Телеграмма». Ее можно определить, воспользовавшись программой arvkreg, которую можно скачать со страницы загрузки ПО UABUFR.

Напомним здесь, что информация о поправках по углу места и азимуту новых АРВК и об их изменениях должна регистрироваться в техническом деле станции.

Файлы конфигурации ASPD.CNF и ARVK2BFR.CNF не имеют обязательных параметров, требующих явного указания, что позволяет приступить к знакомству и освоению работы с ПО UABUFR с помощью программы TrainingCenter.exe. Однако для полноценного использования ПО в оперативной работе нужно как минимум задать заголовки и способ отправки сообщений в файле ASPD.CNF.

Заголовки и ряд других параметров формирования сообщений в коде BUFR и текстовых сообщений задаются в соответствующих разделах файла ASPD.CNF: BUFR, FM35, SLOY и PRIZ. В большинстве случаев, кроме задания заголовков параметры в этих разделах не требуют явного определения, если только автоматически формируемые штатным ПО обработки не требует ручного переформатирования наблюдателями до отправки в каналы связи. ПО UABUFR позволяет модифицировать отдельные элементы текстовых сообщений: задавать или заменять заголовки, отличительные группы, разделители, конец сообщения. Например, если задать для параметров FM35/TEMPOrgSep и FM35/TEMPSep значения соответственно '=' и '-', а для параметра FM35/TEMPTail значение '#$0D#$0AНННН', то в передаваемых телеграммах КН-04 в символом конца текста будет '-', а строкой конца сообщения будет 'НННН'.

Для сообщений в коде BUFR предусмотрены следующие возможности для отправки в каналы связи:

Таблица 3. Определения индексов метода отправки, используемых для задания параметра SPOOLING/BUFR

BUFR= | Определение
0 | Отправка не производится
1 | Файл с сообщением BUFR копируется в папку, заданную параметром BUFRSave
2 | Загрузка на FTP сервер по протоколу FTP ВМО
3 | Отправка по электронной почте с использованием сторонних почтовых программ, поддерживающих интерфейс Windows Simple MAPI (Outlook Express, Microsoft Office Outlook, Windows Mail, TheBat!)
4 | Отправка по электронной почте с использованием встроенного почтового клиента

Для текстовых сообщений предусмотрены следующие возможности для отправки в каналы связи:

Таблица 4. Определения индексов метода отправки телеграмм, используемых для задания параметра SPOOLING/TLG

TLG= | Определение
0 | Сообщение копируется в буфер обмена
1 | Файл с сообщением копируется в папку, заданную параметром TLGSave
2 | Загрузка на FTP сервер по протоколу FTP ВМО
3 | Отправка по электронной почте с использованием сторонних почтовых программ, поддерживающих интерфейс Windows Simple MAPI (Outlook Express, Microsoft Office Outlook, Windows Mail, TheBat!)
4 | Отправка по электронной почте с использованием встроенного почтового клиента

Параметры загрузки на FTP сервер и задаются раздельно для сообщений в коде BUFR и для текстовых сообщений задаются в разделах FTPBIN и FTPTXT, которые имеют аналогичный набор параметров. Обязательными для задания являются адрес сервера, логин и пароль.

Аналогично раздельно задаются и параметры отправки по электронной почте в разделах соответственно MAILBIN и MAILTXT и SMTPBIN и SMTPTXT. В первых двух разделах задаются параметры, которые используются для отправки сообщений электронной почты как с использованием сторонних почтовых программ, так и с помощью встроенного почтового клиента: адресат и тема сообщений (для каждого вида отправляемых сообщений). Для отправки почтовых сообщений средствами встроенного клиента дополнительно необходимо задать адрес почтового сервера, логин и пароль. При необходимости скрыть пароль доступа к почтовому ящику или FTP-серверу можно воспользоваться программой makepwd со страницы загрузки ПО.

В файле arvk2bfr.cnf задаются общие параметры. Рекомендуется явно задавать путь к корневой папке архива файлов данных используемого ПО обработки данных, т.к. значение, выбираемое программой по умолчанию, может не соответствовать реальному. На этапе освоения ПО рекомендуется задавать OPTIONS/ObserverOn=1, чтобы обеспечить возможность ввода оператором ФИО старшего дежурной смены через интерфейс ПО BUFR, однако в дальнейшем эту возможность стоит отключать во избежание ошибок. Список ФИО старших дежурной смены можно задать явно в файле ascvar.cnf - пример приведен в приложении.

Для обеспечения включения в часть B сообщения КН-04 национального раздела 10 (согласно изменению № 7 к «Коду для передачи данных температурно-ветрового зондирования атмосферы (КН-04)», которое вводится в действие с 1.07.2017) необходимо задать FM35/61616=1.

Неиспользуемые разделы и комментарии можно из файлов конфигурации можно удалить.

3. Параметры командной строки

Помимо файлов конфигурации управлять особенностями работы ПО можно и с помощью параметров командной строки. Общий формат вызова программы с параметрами командой строки

uabufr.exe /Key <Value>

или

uabufr.exe -Key <Value>

где

Key – ключ;

Value – значение ключа (используется не для всех ключей), следующий после ключа после пробела.

Параметры командой строки могут сочетаться в произвольном порядке. Регистр, в котором набраны ключи и их значения, значения не имеют.

При необходимости использования параметров командой строки в оперативной работе для удобства наблюдателей рекомендуется создавать для этого ярлыки или командные файлы.

3.1. Задание папки для файлов конфигурации

По умолчанию файлы конфигурации должны находиться в рабочей папке программы c:\uacoder\bin. Для использования файлов конфигурации (кроме файла ascvar.cnf), размещенных в произвольной папке, программа должна быть запущена командой:

uabufr.exe /C DIR

где

Dir – обязательный параметр: путь к папке, где находятся файлы конфигурации.

Использование альтернативных конфигураций обеспечивает возможность более гибкого использования программы в разных ситуациях. Например, на АЭ поочередно используется два комплекса радиозондирования, при этом для передачи результатов в каналы связи используется отдельная ПЭВМ, соединенная с ПЭВМ комплексов радиозондирования локальной сетью: использование программы с альтернативными файлами конфигурации позволяет работать с ней на ПЭВМ, выделенной для передачи данных. Для этого на этой ПЭВМ создается два ярлыка, вызывающие программу с ключом /C с разными значениями параметра. Другой пример – использование на одной и той же ПЭВМ двух разных конфигураций: одна - для регулярной передачи данных с высоким вертикальным разрешением, другая – для передачи меньшего объема данных в случае проблем с каналами связи.

Даже при использовании ключа С программа использует файл конфигурации ascvar.cnf из папки программы, что обеспечивает, например, сквозную нумерацию выпусков, При необходимости использования разных файлов ascvar.cnf может быть использован ключ AC. При вызове программы командой

uabufr.exe /AC

используется ascvar.cnf из рабочей папки программы.

3.2. Запуск программы со свернутым окном

При запуске программы командой:

uabufr.exe /M

программа сворачивается на панель задач.

3.3. Проверка отправки сообщения BUFR перед выходом из программы

При запуске программы командой:

uabufr.exe /Q

перед завершением работы программы BUFR выдается предупреждение, если не было ли отправлено ни одно сообщение BUFR. Сочетание использования ключей /Q и /M с помещением программы uacoder.exe в автозагрузку может быть использовано на этапе освоения ПО для напоминания наблюдателям о необходимости отправки сообщения BUFR, т.к. программа выдает соответствующее предупреждение перед выключением ПЭВМ.

3.4. Сохранение протокола работы программы

Для сохранения в целях диагностики протокола работы программы, она должна быть запущена командой:

uabufr.exe /L LogFileName

где

LogFileName – обязательный параметр: имя файла протокола.

Если LogFileName уже существует, он дополняется новыми записями.

Приложение 1

Файлы конфигурации ПО UABUFR командной строки

Файл настроек параметров станции и системы радиозондирования station.cnf

;параметры АЭ и системы зондирования

;=====================================================================

;информация о станции:Координаты и индексный номер и т.д.

[Station]

;!D:Широта в ° с точностью до 0,00001°(южная с минусом)

;например, 55.93123

StationLat=

;!D:Долгота в ° с точностью до 0,00001°(западная с минусом)

;например, 37.51833

StationLon=

;!D:Высота нуля барометра в м с точностью до 0,1 м

StationBarometerHeight=

;!D:Высота метеоплощадки в м с точностью до 0,1 м

StationGroundHeight=

;!D:Высота места выпуска в м с точностью до 1 м

StationRSReleaseHeight=

;!N:Индексный номер АЭ

StationInd=

[ARVK]

;!N:Индекс системы зондирования (см. Таблицу 2)

ARVK=

;L:Единственный новый АРВК на станции

;single=1

;!N:порядковый номер применяемого наземного комплекса (обязателен, если single=0)

;ARVKnum=

;!N:высота антенны над уровнем нуля барометра с точностью до 1 м

AntennaHeightAbove=

;!D:Поправка по азимуту для МАРЛ-А и Вектор-М с точностью до 0.01°(для АВК задаваться не должна!)

;CorrAz=

;!D:Поправка по углу места для МАРЛ-А и Вектор-М с точностью до 0.01°(для АВК задаваться не должна!)

;CorrEl=

;!L:Наличие радиопрозрачного укрытия (РПУ), 1 - имеется

Radome=

;!T:Версия ПО обработки, 12 символов

SoftVer=

Файл настроек параметров формирования и отправки сообщений в каналы aspd.cnf

;Настройки параметров формирования и отправки сообщений

;в каналы связи по электронной почте или ФТП

;=====================================================================

;Способ отправки сообщений

[SPOOLING]

;N:отправка BUFR:0-нет,1-файл,2-FTP,3-e-mail(MAPI),4-SMTP

;BUFR=1

;N:отправка текстовых сообщений:0-буфер обмена,1-файл,2-FTP,3-e-mail(MAPI),4-SMTP

;TLG=1

;T:Путь для сохранения отправленных сообщений BUFR

;если не задан, никаких действий не производится

;BUFRSave=

;T:Путь для сохранения отправленных текстовых сообщений

;если не задан, сообщения сохраняются в папке с исходными данными

;TLGSave=

;=====================================================================

;Параметры для комплекса АВК-АРМ Аэролога

;[ARM]

;T:папка в которой ПО ОРД сохраняет телеграммы

;TLGPath=С:\ARM\

;L:Использовать расширение .txt для файлов телеграмм

;TXTExt=0

;=====================================================================

;Параметры формирования сообщений в коде КН-04

[FM35]

;T:Начальная строка и сокращенный заголовок для части А

;например ZCZC#$20333#$0D#$0AUSRS10#$20RUMS#$20{ddhh}00<BBB>#$0D#$0A

;AHead=

;T:Начальная строка и сокращенный заголовок для части B

;например 333#$0D#$0AUKBY01#$20UMMN#$20{ddhh}00<BBB>#$0D#$0A

;BHead=

;T:Начальная строка и сокращенный заголовок для части C

;CHead=

;T:Начальная строка и сокращенный заголовок для части D

;T:DHead=

;T:символ(ы) перед <BBB>

;TEMPBBBHead=#$20

;T:символ(ы) после <BBB>

;TEMPBBBTail=

;T:отличительная группа для части А в исходных файлах

;AOrgSecHead=TTAA

;T:отличительная группа для части B в исходных файлах

;BOrgSecHead=TTBB

;T:отличительная группа для части C в исходных файлах

;COrgSecHead=TTCC

;T:отличительная группа для части D в исходных файлах

;DOrgSecHead=TTDD

;T:отличительная группа для частей А, B, C и D в передаваемом сообщении

;используется только, если требуется ее замена, например на группы ЩЭГАО

;ASecHead=

;BSecHead=

;CSecHead=

;DSecHead=

;T:символы конца строки

;CRLF=#$0D#$0A

;T:символ(ы) конца текста в исходных файлах

;TEMPOrgSep='='

;T:символ(ы) конца текста в передаваемом сообщении

;используется только, если требуется замена, например '=' на '-'

;TEMPSep=''

;T:текст для конца сообщения

;TEMPTail=#$0D#$0ANNNN

;=====================================================================

;Параметры формирования сообщений ПРИЗЕМНЫЙ СЛОЙ

[PRIZ]

;T:Начальная строка и сокращенный заголовок

;например ЗЦЗЦ#$2031#$201100411#$0D#$0AУУРС40#$20МСКВ#$20{ddhh}00<BBB>

;PrizHEAD=

;T:строка нулевого раздела, например 'ПРИЗЕМНЫЙ СЛОЙ STIND {ddhh}00'

;используется для комплекса АВК-АРМ Аэролога

;PrizSecHead=''

;T:символ(ы) конца текста в исходных файлах

;PrizOrgSep=

;T:символы конца строки

;CRLF=#$0D#$0A

;T:символ(ы) конца текста в передаваемом сообщении

;PrizSep=

;T:текст для конца сообщения

;PrizTail=#$0D#$0AНННН

;T:символ(ы) перед <BBB>

;PrizBBBHead=#$20

;T:символ(ы) после <BBB>

;PrizBBBTail=

;=====================================================================

;Параметры формирования сообщений СЛОЙ

[SLOY]

;T:Начальная строка и сокращенный заголовок

;например ЗЦЗЦ#$2031#$20110041/#$0D#$0AЗВРС40#$20МСКВ#$20{ddhh}00

;SLOYHEAD=

;T:отличительная группа исходных файлах

;SLOYOrgSecHead=СЛОЙ

;T:отличительная группа в передаваемом сообщении

;используется, если требуется отличительная группа

;SLOYSecHead=

;T:символ(ы) конца текста в исходных файлах

;SLOYOrgSep=

;T:символ(ы) конца текста в передаваемом сообщении

;SLOYSep=

;T:текст для конца сообщения

;SlOYTail=

;L:признак замены ВСВ на местное время

;SLOYLoc=0

;N:часовой пояс (разница между местным временем и ВСВ)

;UTCBias=0

;L:признак включения даты и срока в сообщение

;SLOYYYGG=0

;T:отличительная цифра группы с датой и сроком

;YYGGChar='0'

;L:признак передачи группы с датой и сроком перед индексом станции,

;SLOYYYGG1st=0

;L:передача данных о среднем ветре в км/ч (только если ПО обработки выдает две телеграммы СЛОЙ)

;SLOYmph=0

;L:признак исключения из сообщения индекса станции

;SLOYNoIndex=0

ч;=====================================================================

;Параметры формирования сообщений в коде BUFR

[BUFR]

;!T:Заголовок для сообщений BUFR с данными до 100 гПа

;например IUKD90#$20RUMS#$20{ddhh}00<BBB>

;IUKHead=IUKD90#$20RUMS#$20{ddhh}00<BBB>

;!T:Заголовок для сообщений BUFR с данными всего выпуска

;IUSHead=IUSD90#$20RUMS#$20{ddhh}00<BBB>

;T:символ(ы) перед <BBB>

;BUFRBBBHead=#$20

;T:символ(ы) после <BBB>

;BUFRBBBTail=

;T:Указатель центра (для включения в название файла)

;CCCC=RUMS

;L:Использовать короткую форму имени файла

;например, A_TUSD90RUMS110000_27612.bin

;пример длинной формы A_TUKD90RUMS110000_C_RUMS_20160724121844_27612.bin

;ShortName=0

;L:Оформлять файл с данными BUFR как бюллетень согласно схеме

;<soh><cr><cr><lf>T1T2A1A2ii<sp>CCCC<sp>YYGGgg<cr><cr><lf><BUFR-data><cr><cr><lf><etx>

;WMOMssgFmt=1

;N:Центр-поставщик, 4-Москва

;Center=4

;N:Под-центр-поставщик

;SubCenter=0

;=====================================================================

;Общие параметры отправки по e-mail текстовых сообщений

;раздел не используется и может отсутствовать, если передача

;текстовых сообщений по e-mail не используется

[MAILTXT]

;!T:адресат отправителя, например ae30101@ugms.mecom.ru

;необязателен для отправки через внешний почтовый клиент

;MailFrom=

;!T:адресаты для отправки, например unimas1@ugms.mecom.ru

;MailTo=

;T:адресаты CC:

CCTo=alexander.kats@cao-rhms.ru

;T:адресаты BCC:

;BCCTo=

;T:поле Тема для TTAA

;например, TTAA AE30101:{yymm-dd:hh}

;SubjA='TTAA:{yyyymmdd-hh}'

;T:поле Тема для TTBB

;SubjB='TTBB:{yyyymmdd-hh}'

;T:поле Тема для TTCC

;SubjC='TTCC:{yyyymmdd-hh}'

;T:поле Тема для TTDD

;SubjD='TTDD:{yyyymmdd-hh}'

;T:поле Тема для СЛОЙ

;SubjSloy='SLOY:{yyyymmdd-hh}'

;T:поле Тема для ПРИЗЕМНЫЙ СЛОЙ

;SubjPriz='PRIZ:{yyyymmdd-hh}'

;=====================================================================

;общие параметры отправки BUFR по e-mail

;раздел не используется и может отсутствовать, если передача BUFR по

;e-mail не используется

[MAILBIN]

;!T:адресат отправителя, например ae30101@ugms.mecom.ru

;необязателен для отправки через внешний почтовый клиент

;MailFrom=

;!T:адресаты для отправки, например unimas2@ugms.mecom.ru

;MailTo=

;T:адресаты CC:

CCTo=alexander.kats@cao-rhms.ru

;адресаты BCC:

;T:BCCTo=

;T:поле Тема для бюллетеня IUK

;например, BUFR-AB<BBB>AE30101:{yymm-dd:hh}

;Subj2AB=IUK:{yyyymmdd-hh}

;T:поле Тема для бюллетеня IUS

;Subj2ABCD=IUS:{yyyymmdd-hh}

;=====================================================================

[SMTPTXT]

;параметры отправки текстовых сообщений встроенными средствами программы

;раздел не используется и может отсутствовать, если передача

;текстовых сообщений встроенными средствами программы не используется

;!T:адрес почтового сервера отправителя, например meteo.ugms.ru или mail.ru:465

;host=

;!T:имя учетной записи пользователя, например ae30101

;login=

;!T:пароль

;kenwort=

;L:Шифрование пароля

;cipher=0

;L:Ключ шифрования

;schlsl=

;L:Автоматическое переключение в режим SSL/TLS если он поддерживается удаленным сервером

;TLS=0

;L:Подключение к серверу в режиме SSL/TLS, как правило требуется указание порта в параметре host

;SSL=0

;N:MIME:0-7bit,1-8bit,2-Quoted-Printable,3-Base64,4-UUE,5-XXE

;mime=0

;Формировать строку boundary

;Mixed=1

;Игнорируется

;ForceMixed=1

;N:Кодировка заголовка сообщения (0-CP1251,1-KOI8_R,2-UTF_7,3-UTF_8)

;HeadKod=1

;N:Кодировка тела сообщения (0-CP1251,1-KOI8_R,2-UTF_7,3-UTF_8)

;TextKod=1

;L:Перекодировка текста сообщения не производится

;Raw=1

;L:Отправка по SMTP в фоне

;Beat=1

;N:Интервал обновления GUI, мс

;Tick=200

;L:Отображение информации о передаче данных

;Status=1

;L:Отображение сообщений сервера

;Info=1

;L:Формирование запроса на подтверждение доставки

;receipt=0

;L:Формирование прерываний при сбоях отправки

;Cancel=0

;=====================================================================

;параметры отправки бинарных сообщений встроенными средствами программы

;текстовых сообщений встроенными средствами программы не используется

[SMTPBIN]

;!T:адрес почтового сервера отправителя, например meteo.ugms.ru или mail.ru:465

;host=

;!T:имя учетной записи пользователя, например ae30101

;login=

;!T:пароль

;kenwort=

;L:Шифрование пароля

;cipher=0

;L:Ключ шифрования

;schlsl=

;L:Автоматическое переключение в режим SSL/TLS если он поддерживается удаленным сервером

;TLS=0

;L:Подключение к серверу в режиме SSL/TLS, как правило требуется указание порта в параметре host

;SSL=0

;N:MIME:0-7bit,1-8bit,2-Quoted-Printable,3-Base64,4-UUE,5-XXE

;mime=0

;Формировать строку boundary

;Mixed=1

;Формировать пустой текстовый раздел

;ForceMixed=1

;N:Кодировка заголовка сообщения (0-CP1251,1-KOI8_R,2-UTF_7,3-UTF_8)

;HeadKod=1

;N:Кодировка тела сообщения (0-CP1251,1-KOI8_R,2-UTF_7,3-UTF_8)

;TextKod=1

;L:Перекодировка текста сообщения не производится

;Raw=1

;L:Отправка по SMTP в фоне

;Beat=1

;N:Интервал обновления GUI, мс

;Tick=200

;L:Отображение информации о передаче данных

;Status=1

;L:Отображение сообщений сервера

;Info=1

;L:Формирование запроса на подтверждение доставки

;receipt=0

;L:Формирование прерываний при сбоях отправки

;Cancel=0

;=====================================================================

;Параметры отправки бинарных сообщений по ФТП

;Раздел не используется и может отсутствовать, если передача BUFR по

;ФТП не используется

[FTPBIN]

;L:Использовать процедуру приложения II-15 ВМО 306

;FTPWMOOLD=1

;!T:адрес сервера

URL=

;!T:логин

USER=

;!T:пароль

PWD=

;L:Шифрование пароля

;encode=0

;L:Ключ шифрования

;enkey=

;T:Папка на сервере для загрузки

;PATH=

;L:Пассивный режим

;PASV=0

;L:Проверять размер загруженного на сервер файла

;CHECKSIZE=1

;L:Вызвать диалог подключения удаленного доступа

;если нет соединения с интернетом

;FORCECONNECT=0

;L:Отключить соединение удаленного доступа после отправки

;FORCEDISCONNECT=0

;N:Таймаут подключения, мс. 0 - не используется

;TOUT_CONNECT=0

;N:Таймаут на прием, мс. 0 - не используется

;TOUT_RECEIVE=0

;N:Таймаут на отправку, мс. 0 - не используется

;TOUT_SEND=0

;Размер блока данных - от 256 до 4096 байт

;CHUNK=1024

;T:Префикс СССС0 в имени файла, загружаемого по ФТП,

;по умолчанию используются последние 4 цифры индексного номера

;CCCC0=

;L:пассивный режим ФТП

;PASV=0

;=====================================================================

;Параметры отправки текстовых сообщений по ФТП

;Раздел не используется и может отсутствовать, если передача BUFR

;передача текстовых сообщений по ФТП не используется

[FTPTXT]

;L:Использовать процедуру приложения II-15 ВМО 306

;FTPWMOOLD=1

;!T:адрес сервера

URL=

;!T:логин

USER=

;!T:пароль

PWD=

;L:Шифрование пароля

;encode=0

;L:Ключ шифрования

;enkey=

;T:Папка на сервере для загрузки

;PATH=

;L:Пассивный режим

;PASV=0

;L:Проверять размер загруженного на сервер файла

;CHECKSIZE=1

;L:Вызвать диалог подключения удаленного доступа

;если нет соединения с интернетом

;FORCECONNECT=0

;L:Отключить соединение удаленного доступа после отправки

;FORCEDISCONNECT=0

;N:Таймаут подключения, мс. 0 - не используется

;TOUT_CONNECT=0

;N:Таймаут на прием, мс. 0 - не используется

;TOUT_RECEIVE=0

;N:Таймаут на отправку, мс. 0 - не используется

;TOUT_SEND=0

;Размер блока данных - от 256 до 4096 байт

;CHUNK=1024

;T:Префикс СССС0 в имени файла, загружаемого по ФТП,

;по умолчанию используются последние 4 цифры индексного номера

;CCCC0=

;L:пассивный режим ФТП

;PASV=0

Файл настроек постоянных настроек программного обеспечения arvk2bfr.cnf

;Файл постоянных настроек ARVK2BFR

[OPTIONS]

;T:корневой каталог файлового архива ПО обработки данных

;пример:c:\eol\archive\{yyyy\m}

;пример:c:\apmarl\{yyyy\mm}

;пример:c:\arm\data

;пример c:\vector211\Archive

;src=

;N:Политика задания типа радиозонда/системы зондирования

;0 - жестко задается в файле ascvar.cnf - если не задана, по умолчанию первый из возможных

;1 - используется информация, сохраненная в файлах данных

;    только для МАРЛ, Вектро-М, АРМ Аэролога, в противном случае - 0

;    в случае ошибок используется информация из ascvar.cnf

;2 - используется информация, сохраненная в файлах данных

;    только для МАРЛ, Вектро-М, АРМ Аэролога, в противном случае - 4

;    оператор имеет возможность ее изменить

;3 - задается/изменяется оператором, если информация, сохраненная в файлах данных,

;    отличается, оператору предлагается возможность ее использовать

;4 - задается/изменяется оператором - информация, сохраненная в файлах данных, игнорируется

;если кодовые цифры, сохраненные в файлах данных, более не применяются, и выбор оператором не предусмотрен

;используются либо кодовые цифры по умолчанию, либо заданные в ascvar.cnf

;RaRaOn=2

;L:Допускает возможность повторных выпусков. Если 0, выбор "Повторный выпуск" недоступен

;Repeated=0

;L:Включает возможность ввода оператором ФИО старшего смены

;в противном случае необходимо задать их вручную в файле ascvar.cnf

;ObserverOn=1

;L:Допускает возможность использования указателей BBB=RRx. Если 0, отметка "RRx" недоступна

;обычно указатель RRx при отправке метеорологических сообщения с пункта наблюдений не применяется

;RRx=0

;T:файл настроек кодирования BUFR, относительный путь нужно

;указывать относительно относительно папки программы

;BUFRCNF=BUFRCODES.CNF

;=====================================================================

[TLG]

;L:Включает просмотр телеграмм перед отправкой

;DisplayTLG=1

;L:Разрешает правку телеграмм перед отправкой, игнорируется если DisplayTLG=0

;EditTLG=1

;L:Включает сохранение телеграмм перед отправкой по пути

;заданному параметром TLGCopy в разделе SPOOLING

;SaveTLG=1

;=====================================================================

;настройки редактирования КН-04

[FM35]

;!L:Заменять кодовые цифры радиозонда/системы в части B КН-04 на выбранные

;оператором или заданные, если RaRaOn<>1

;InjectRaRa=1

;!L:Включать в часть B КН-04 национальный раздел с 61616

;61616=0

[BUFR]

;L:Включает просмотр данных перед кодированием

;ViewDATA=1

;L:Включает редактирование данных перед кодированием

;EditDATA=1

Приложение 4

Пример раздела [SMENA] файла сохранения ascvar.cnf с перечнем ФИО дежурных смен

[SMENA]

;Количество смен

N=3

;Фоменко Владимир Леондиович

smena0=ФВЛ

;Максимкина Галина Александровна

smena1=МГА

;Кац Александр Петрович

smena2=КАП

[1] Количество файлов может изменяться в зависимости от версии ПО


UABUFRSetup.doc/05.04.2017 ПО UABUFR: Руководство по установке и настройке программы

1