1. Уровень подготовки пользователей

Для работы с ПО UABUFR операторы ПО должны обладать базовыми навыками работы на ПЭВМ, взаимодействия с графическим пользовательским интерфейсом ОС Windows (клавиатура, манипулятор типа «мышь», управление окнами, в т.ч. диалоговыми, и приложениями, ввод и редактирование информации, файловая система) и опытом использования ПО обработки данных радиозондирования (АП «ЭОЛ», ПО «Телеграмма», ПО ОРД), проведения технического и критического контроля качества аэрологических данных. Для успешного освоения работы с ПО операторам необходимо ознакомиться с его описанием, в первую очередь – описанием основных операций и интерфейса.

Для установки и настройки ПО дополнительно требуются уверенное владение браузером, навигацией по файловой системе с использованием Проводника Windows или иного файлового менеджера (например, Total Commander или Far), приемами работы с архивными файлами ZIP, текстовым редактором, владение информацией о координатах аэрологической станции, применяемой системе зондирования и программного обеспечения обработки, параметрах доступа и учетных записях используемых каналов связи.

2. Рекомендуемая последовательность освоения ПО UABUFR

2.1. Изучение документации

С поставляемой документацией рекомендуется ознакомиться в следующем порядке:

· UABUFRIntro.doc ПО UABUFR: Общие сведения о программе

· UABUFRTrain.doc ПО UABUFR: Руководство по освоению программы

· UABUFRSetup.doc ПО UABUFR: Руководство по установке и настройке программы

· UABUFRInstr.doc ПО UABUFR: Рабочая инструкция оператора

· UABUFRCheck.doc ПО UABUFR: Проверка данных выпуска при подготовке данных в коде BUFR

2.2. Начало работы с ПО

Знакомство с ПО следует начинать с изучения демонстрационных примеров, а полученные навыки закрепить, создавая сообщения BUFR из результатов обработки ранее проведенных выпусков из архива системы радиозондирования.

После ознакомления с документацией установите ПО UABUFR на диск ПЭВМ согласно UABUFRSetup.doc. До того, как настраивать параметры доступа и учетные записи используемых каналов связи в файле конфигурации ASPD.CNF, рекомендуется сначала задать обязательные настройки в файле STATION.CNF и попробовать запустить ПО UABUFR.

Если программа успешно запускается, то, после выхода из нее рекомендуется установить программу TrainingCenter.exe и освоить работу с ПО UABUFR как описано в разделе 3. Если программа не запускается с сообщением «Ошибка загрузки данных станции'», можно записать в папку C:\UACODER\bin демо-файлы конфигурации из архива 27612cnf.zip со страницы http://cao-ntcr.mipt.ru/bufr.

Полученные навыки работы с ПО рекомендуется закрепить, используя результаты обработки ранее проведенных выпусков из файлового архива системы радиозондирования. Для этого после освоения основных приемов работы программы согласно разделу 3 необходимо еще раз проверить настройки в файле STATION.CNF, если использовались демо-файлы конфигурации из архива 27612cnf.zip – исправить их на значения, актуальные для данной аэрологической станции. Затем следует задать в файле ASPD.CNF заголовки и других параметры формирования сообщений в коде BUFR и текстовых сообщений и убедиться, что SPOOLING/BUFR=0 и SPOOLING/TLG=1. В файле arvk2bfr.cnf в OPTIONS/src следует задать путь к корневой папке архива файлов ПО обработки. После этого ПО готово к работе за исключением отправки сообщений в каналы связи. Помимо проверки готовности работы ПО к работе с архивом файлов ПО обработки на этом этапе обязательно надо проверить заголовки формируемых сообщений, а для текстовых сообщений – и их форматы. Для освоения навыков проверки и правки данных рекомендуется использовать данные выпусков, в которых приходилось прибегать к ручной правке сообщений КН-04 для исключения недостоверных данных.

После освоения работы с ПО UABUFR по реальным данным радиозондирования данной аэрологической станции можно настраивать в ASPD.CNF параметры отправки передачи в каналы связи и приступать к тестовой передаче сообщений в коде BUFR.

Возможность работы с данными предыдущих выпусков без отправки сообщений в каналы связи можно сохранить и после начала тестовой передачи, воспользовавшись возможностью вызова ПО UABUFR с альтернативными файлами конфигурации, как описано в UABUFRSetup.doc.

3. Обучение с использованием демонстрационных примеров

3.1. Общие сведения

После настройки ПО UABUFR для освоения и закрепления навыков работы с ней рекомендуется воспользоваться заранее подготовленными демонстрационными примерами, использование которых подробно разобрано ниже. Для работы с демонстрационными примерами ПО UABUFR может быть установлено на любой ПЭВМ, необязательно на ПЭВМ системы радиозондирования - в этом случае настройка параметров передачи сообщений в каналы связи необязательна.

В примерах используются данные выпусков с нескольких аэрологических станций. Файлы и программа, необходимые для работы с демонстрационными примерами, содержатся в папке C:\UACoder\DEMO.

Для работы с демонстрационными примерами в папке DEMO создаются специальные копии файлов настроек, исключающие передачу сообщений в каналы связи. Создаваемые при работе с демонстрационными примерами сообщения и служебные файлы сохраняются только в этой папке и не смешиваются с файловым архивом данных радиозондирования аэрологической станции.

3.2. Установка демонстрационных примеров

Архив uabtraining.zip с программой, обеспечивающей установку на диск ПЭВМ файлов, необходимых для подготовки демонстрационных примеров и работы с ними, размещен на сайте НТЦР ФГБУ «ЦАО» на страницы http://cao-ntcr.mipt.ru/bufr «Передача аэрологических данных в коде BUFR» - прямая ссылка для загрузки последней версии http://cao-ntcr.mipt.ru/bufr/uabtraining.zip.

Для установки на диск ПЭВМ файлов, необходимых для подготовки демонстрационных примеров и работы с ними, необходимо извлечь из архива uabtraining.zip программу uabtraining.exe и запустить ее на исполнение. При работе в Windows версии Vista и более поздними может потребоваться подтверждение запуска программы demo.exe и запускаемой ею вспомогательной служебной программы setuplink.exe.

После запуска программы установки нажмите кнопку «Извлечь файлы»:

Рисунок 1. Окно программы установки ПО для обучения

Дождитесь появления сообщения «Извлечено .. файлов»[1] и нажмите кнопку «Закрыть»:

Рисунок 2. Окно программы установки после извлечения файлов из архива

Исходные данные и файлы для работы с демонстрационными примерами будут записаны в папку C:\UACoder\Demo.

Для подготовки демонстрационных примеров и запуска ПО UABUFR используется TrainingCenter.exe, которая описана ниже. Для запуска пакетных файлов рекомендуется использовать Проводник Windows или ярлык на Рабочем столе:

Рисунок 3. Ярлык программы TrainingCenter на Рабочем столе

При необходимости (например, в случае непреднамеренного удаления или изменения какого-либо файла), исходные файлы можно восстановить, повторно запустив программу uabtraining. Если запустить программу uabtraining с ключом verbose, можно выбрать нужные файлы в списке файлов с тем, чтобы исключить утерю настроек, уже внесенных в файлы конфигурации, и определить действия при извлечении файлов, которые уже находятся на жестком диске. Программа uabtraining представляет собой самораспаковывающейся архив самого распространенного формата ZIP, из которого можно извлекать файлы, используя сторонние программы работы с архивами такие как WinRAR, 7-ZIP, Total Commander.

Программа установки и собственно программа TrainingCenter не создает никаких записей в реестре Windows, для ее удаления достаточно удалить папку C:\UACODER\Demo и ярлык программы TrainingCenter с Рабочего стола Windows.

До первого запуска программы TrainingCenter необходимо установить ПО UABUFR и настроить данные аэрологической станции и системы радиозондирования в файле STATION.CNF в папке C:\UACoder\bin.

3.3. Подготовка данных

В комплект ПО входят данные трех выпусков для каждой системы радиозондирования – для срок 00 и 12 ВСВ текущего дня и 12 ВСВ предыдущего. Для подготовки к работе с данными этих выпусков демонстрации запустите программу TrainingCenter (предварительно должна быть установлена программа UABUFR и внесены необходимые настройки в файле STATION.CNF!).

Рисунок 4. Интерфейс программы TrainingCenter

Выберите в списке используемую систему радиозондирования и программное обеспечение обработки. Если используемое программное обеспечение обработки создает файлы с результатами обработки с высоким вертикальным разрешением (файлы prof, edt, res), установите отметку «Высокое разрешение».

Начать знакомство с ПО UABUFR можно с примера №1, хотя это необязательно – просто в данных этого примера нет ошибочных данных. Выберите номер примера, нажмите кнопку «Подготовить пример» и дождитесь появления сообщения «Файлы с данными для примера №… готовы» - был создан временный архив с файлами данных радиозондирования для текущих суток и предыдущего дневного срока, сгенерированных из данных выпуска соответствующего примера (т.е. данные каждого выпуска во временном архиве идентичны за исключением срока и времени выпуска). Одновременно с этим в папку Demo копируются с необходимыми модификациями файлы с настройками ПО UABUFR.

В процессе подготовки данных может производиться очистка временного архива от данных – в этом случае необходимо подтвердить запрос (вид запроса зависит от версии Windows) на их удаление – в противном случае возможны накладки при загрузке результатов правки от разных примеров.

Рисунок 5. Запрос на удаление временного архива демонстрационных данных

После завершения копирования файлов настроек и данных можно перейти к работе с демонстрационными данными.

3.4. Запуск ПО UABUFR для работы с демонстрационными данными

После подготовки временного архива с данными выбранного примера нажмите кнопку «Запустить ПО кодирования» - запустится ПО UABUFR, настроенное на работу с данными из временного архива. Для завершения работы с программой TrainingCenter нажмите клавиши Alt+F4 или кнопку ý в правом верхнем углу окна программы.

3.5. Демонстрационные примеры

3.5.1. Работа с данными МАРЛ-А

Пример №1:

После запуска программы UABUFR нажмите кнопку «Выпуск», в диалоге выбора выпуска выберите файл с начальными данными последнего выпуска за текущую дату

Рисунок 6. Диалог выбора выпуска (для данных АП МАРЛ)

В зависимости от начальных установок типа радиозонда/системы зондирования может быть выдан запрос вида:

Рисунок 7. Запрос при несоответствии выбора типа радиозонда в ПО информации, сохраненной в файле info

На данном этапе выберите любой из прилагаемых вариантов. Нажмите клавишу табуляции клавиши табуляции ↹ и, последовательно перемещаясь от одного поля ввода к другому, введите номер выпуска, инициалы старшего дежурной смены (в русском регистре), выберите тип радиозонда «И-2012 1680 МГц», введите серийный номер радиозонда и значение подъемной силы как указано на рис. 10 – обратите внимание, что по мере перемещения от поля к полю изменяется цвет шрифта с красного на синий – в тех полях, где информация вводилась или изменялась, и на черный – где информация не изменялась. После того, как был изменен выбор типа радиозонда/системы радиозондирования, стала доступной кнопка «ТТВВ».

Рисунок 8. Ввод/подтверждение информации о выпуске в главном окне программы

После подтверждения длины подвески становится доступной и кнопка «BUFR I».

Нажмите кнопку «BUFR I», появится окно «Проверка данных» с данными до уровня 100 гПа включительно.

Понажимайте кнопки Alt+F12, F12, F11, чтобы ознакомиться с графическим представлением профилей температуры, точки росы и геопотенциала, направления и скорости ветра, траектории полета радиозонда, которые будут закодированы в коде BUFR, и переключением отображения диаграмм с соответствующими графиками.

Нажмите кнопку F10, чтобы переключиться в таблицу с данными выпуска (или просто щелкните мышкой по любой из строчек в таблице).

Первоначально в таблице подсвечен самый первый уровень, что означает, что этот уровень является выбранным. Понажимайте на клавиатуре кнопки управления курсором ↑, ↓, PgUp, PgDn, Home, End, чтобы ознакомиться с навигацией по таблице. Обратите внимание, что выбранный в данный момент в таблице уровень отображается на диаграммах TH и DV тонкой горизонтальной линией, а на графике XY – голубой точкой. Для прокручивания таблицы можно также использовать колесо мыши (если используется мышь, оснащенная колесом прокрутки), а также вертикальную полосу прокрутки справа от таблицы. Для этого нужно навести курсор мыши на ползунок на полосе прокрутки, нажать левую кнопку и, не отпуская ее, перемещать мышь вверх-вниз. Можно также щелкать мышкой значок Λ вверху и значок V внизу полосы прокрутки. Обратите внимание, что при использовании мыши для прокрутки выбор уровня в таблице не изменяется. Щелкните мышью по любой строке в таблице – эта строка становится выбранной.

Рисунок 10. Окно проверки данных

Понажимайте на клавиатуре кнопки управления курсором → и ←, чтобы ознакомиться с прокруткой по горизонтали, чтобы отобразить колонки таблицы, не помещающиеся на экране. Горизонтальную прокрутку таблицы можно выполнять и с помощью горизонтальной полосы прокрутки, расположенной снизу от таблицы.

Справа от вертикальной полосы прокрутки расположена вертикальная черта, перемещая которую с помощью мыши, можно изменять относительные размеры таблицы и диаграмм.

Нажмите кнопку «ОК» и подтвердите отправку. В папке c:\UACoder\demo\apmarl\ГГГГ\ММ\ будет создан файл с сообщением в коде BUFR с данными до 100 гПа включительно. Его можно просмотреть с помощью программы CBUFR (http://cao-rhms.ru/update/bufr/bufrde.htm).

Обратите внимание, что в главном окне программы UABUFR название кнопки «BUFR I», теперь перечеркнуто, что означает, что сообщение с данными выпуска до уровня 100 гПа сформировано и отправлено.

Проделайте те же самые действия с данными выпуска за срок 00 ВСВ за текущую дату (данные выпусков идентичны). Обратите внимание, что в этот раз при загрузке выпуска предлагается оставить кодовые цифры 60. После завершения формирования сообщения BUFR с данными до уровня 100 гПа нажмите кнопку «Выход».

Вновь запустите программы TrainingCenter (настройки должны были сохраниться) и опять нажмите кнопку «Запустить ПО кодирования» - запустится программа UABUFR. Если с последнего стандартного срока прошло менее 6 часов, будут загружены информационные данные (номер выпуска и другие), введенные на предыдущем этапе. В противном случае, нажмите кнопку «Выпуск» и откройте тот же файл INFO за последний срок, который открывали раннее – будут загружены ранее введенные информационные данные. Для подтверждения ранее введенной информации последовательно щелкните правой кнопкой мыши по меткам полей ввода - от метки «№» до метки «Длина подвеса»:

Рисунок 11. Повторная загрузка выпуска – подтверждение ранее введенной информации

Обратите внимание, как меняется цвет шрифта с красного на черный и становятся доступными кнопки «TTBB» и «BUFR I». Выберите причину прекращения выпуска «Разрыв оболочки» и нажмите кнопку «BUFRII» - откроется окно проверки данных. Обратите внимание, что на этот раз в него загружены данные всего подъема. Нажмите кнопку «ОК» и подтвердите отправку. Обратите внимание, что теперь название кнопки «BUFRII», также перечеркнуто, что означает, что сообщение с данными всего выпуска сформировано и отправлено. Нажмите кнопку «Выход».

Вновь запустите программу UABUFR из программы TrainingCenter как указано выше и откройте тот же файл INFO за последний срок, который открывали раннее. Подтвердите информацию о выпуске с помощью мыши или используя клавишу табуляции ↹, но измените выбор типа радиозонда/системы радиозондирования:

Рисунок 12. Повторная загрузка выпуска – изменение ранее введенной информации

Обратите внимание, что цвет шрифта поля «Радиозонд/система» изменился на синий, указывая, что информация изменена, а кнопок «BUFR I», «BUFRII» и надпись у рамки «BBB» изменился на красный, указывая на необходимость отправки исправленного сообщения. Установите отметку «+» в рамке «BBB», в правой части рамки появится надпись «ССА». Нажмите кнопку «BUFR I» и повторите отправку сообщения BUFR с данными до 100 гПа, а затем кнопку «BUFRII» и повторите отправку сообщения BUFR с данными всего выпуска. Будут сформированы и отправлены сообщения с указателем ССА, которые будут сохранены в папке c:\UACoder\demo\apmarl\ГГГГ\ММ\. Предыдущие, первоначальные сообщения при этом также сохраняются на диске. Например, если файл с оригинальным сообщением с данными до 100 гПа имеет название A_IUKD90RUMS241200_C_RUMS_201702241130_27612.bin, то первое сообщение с исправлением имеет название, в которое включен указатель ССА: A_IUKD90RUMS241200CCA_C_RUMS_201702241130_27612.bin. Последующие исправления вместо ССА будут иметь в названии CCB, CCC и так далее. Обратите внимание на изменение текста надписи на кнопках «BUFR I» и «BUFRII» после отправки сообщений с исправлениями – они включают в себя последний указатель CCx, с которым было отправлено сообщение – на это необходимо обращать внимание при необходимости отправки последующих исправлений, чтобы исключить подачу разных сообщений с одинаковыми указателями CCx.

Рисунок 13. Отправка сообщения с исправлениями

Откройте файл INFO за срок 12 ВСВ предыдущего дня, подтвердите или введите необходимую информацию и нажмите кнопку «BUFR I» или «BUFRII» - будет выдано сообщение об отсутствии файла GROUND с данными в приземном слое. В оперативной работе продолжение допустимо только если ПО «Телеграмма» не может создать сообщение «ПРИЗЕМНЫЙ СЛОЙ».

Пример №2:

Подготовьте данные для примера №2 аналогично тому, как были подготовлены данные для примера №1. Перед подготовкой данных примера необходимо завершить работу программы UABUFR.

Запустите программу UABUFR и загрузите данные, нажмите кнопку «Выпуск», в диалоге выбора выпуска выберите файл с начальными данными последнего выпуска за текущую дату, введите необходимую информацию и нажмите кнопку «BUFR I» как указано выше.

Рисунок 14. Запрос на создание нового файла

Если не были удалены временные файлы, может быть выдано сообщение «Файл уже существует» с названием ранее созданного файла с сообщением в коде BUFR (см. рис. 14) - нажмите кнопку «Создать новый»,чтобы создать новое сообщение в коде BUFR. Нажмите кнопку F12 или щелкните мышкой по ярлыку закладки «DV(F12)», чтобы вывести на экран диаграмму с графиками направления и скорости ветра.

Как видно из графика, данные ветра недостоверны на уровнях от 300 до 257,2 гПа (для данного выпуска причина брака – ошибка обработки программы «Телеграмма»). Данные ветра на этих уровнях нужно удалить из создаваемого сообщения. Для этого сначала необходимо выделить в таблице данных уровни, принадлежащие этому слою

Рисунок 15. Окно проверки данных с недостоверными данными ветра

Для этого нужно воспользоваться любым наиболее удобным для оператора способом из следующих:

- Вариант I: В таблице данных выберите строку с данными на уровне 300 гПа, пользуясь клавишами PgUp и ↑, ↓. Затем нажмите клавишу Shift и, удерживая ее, последовательно несколько раз нажмите клавишу ↓, пока не дойдете до уровня 257,2 гПа. Если промахнетесь – чтобы вернуться назад, воспользуйтесь клавишей ↑, по-прежнему удерживая клавишу Shift.

- Вариант II: Прокрутите таблицу данных, используя колесо прокрутки мыши или вертикальную полосу прокрутки, до уровня 300 гПа. Выделите мышью строку с данными на уровне 300 гПа, затем нажмите клавишу Shift и, удерживая нажатой левую кнопку мыши, перемещайте мышь вниз до уровня 257, 2 гПа. Отпустите кнопку мыши по достижению требуемого результата.

- Вариант III: На графике с профилем скорости ветра щелкните правой кнопкой мыши на точке со скоростью ветра 19 м/с на уровне 300 гПа, а затем левой кнопкой мыши – на точке со скоростью ветра 55 м/с на уровне 257,2 гПа.

- Вариант IV: Щелкните левой кнопкой мыши над любой точкой на графике с профилем направления или скорости ветра. На диаграмме появится закрашенная прямоугольная область, а в таблице данных будет выделен слой с соответствующими уровнями. Наведите курсор мыши на эту область, нажмите левую кнопку мыши и, удерживая ее, перемещайте область выделения вверх и вниз, чтобы она захватила частично или полностью слой от 300 до 257,2 гПа. Отпустите кнопку мыши по достижению требуемого результата. Затем наведите курсор мыши на любую из границ этой области, нажмите левую кнопку мыши и, удерживая ее, перемещайте нужную границу до достижения соответственно верхней или нижней границы слоя. Отпустите кнопку мыши по достижению требуемого результата.

Варианты использования клавиатуры и мыши можно комбинировать. Каждый оператор может подобрать наиболее удобный для него способ. Потренируйтесь с выделением заданного слоя до уверенного достижения нужного результата.

Получившееся выделение должно выглядеть, как указано на рисунке выше.

Рисунок 16. Исключение недостоверных данных ветра

После выделения уровней в слое от 300 до 257,2 гПа для исключения недостоверных данных ветра в выделенном слое из формируемого сообщения BUFR нажмите клавишу F6 или кнопку «W(F6)». Обратите внимание – теперь в таблице все значения направления и скорости ветра в слое от 300 до 257,2 гПа зачеркнуты, уровни с забракованными значениями выводятся шрифтом коричневого цвета, а точки, соответствующие забракованных значениям, выделены цветом на графиках. Это значит, что они будут исключены из формируемого сообщения BUFR.

Установите отметку «?» вверху формы проверки данных – теперь автоматическое масштабирование графиков направления и скорости ветра осуществляется без учета забракованных значений.

Рисунок 17. Масштабирование без учета недостоверных данных ветра

Теперь нажмите клавиши Alt+F12 или щелкните мышкой по ярлыку закладки «XY(Alt+F12)», чтобы вывести на экран диаграмму с траекторией перемещения радиозонда. В таблице данных выделите, используя уже освоенные приемы (варианты I-III, уровни с 279,3 по 269,7 гПа – на графике траектории они отображаются точками другого цвета (см. рис. 18).

Как можно было бы убедиться из анализа сырых данных этого выпуска, программа Телеграмма ошибочно обработала данные азимута при переходе антенны АРВК через Север при высоких углах места, что и привело к недостоверным значениям направления и скорости ветра в результатах обработки. Для анализа недостоверных данных рекомендуется использовать программу «АРХИВ-АП-М» /http://komet.webzone.ru/kats/apchivel.htm/. Обратите внимание, что ошибки обработки координат произошли в более узком слое с 279,3 по 269,7 гПа, но повлияли на вычисление направления и скорости ветра в более протяженном слое на от 300 до 257,2 гПа. Нажмите клавишу F7 или кнопку «XY(F7)» для исключения данных о координатах радиозонда в выделенном слое из формируемого сообщения BUFR. Обратите внимание, что после этого изменилось отображение траектории, т.к. при установленной отметке «?» забракованные значения не учитываются при масштабировании графика, а сами забракованные значения на графике выделены цветом, а таблице данных выводятся зачеркнутым шрифтом (см. рис. 19).

Рисунок 18. Окно проверки данных с недостоверными данными о траектории полета радиозонда

Рисунок 20. Исключение недостоверных о траектории полета радиозонда

Нажмите кнопку «ОК» и подтвердите отправку данных с изменениями. В папке c:\UACoder\demo\apmarl\ГГГГ\ММ\ будет создан файл с сообщением в коде BUFR с данными до 100 гПа включительно. Нажмите кнопку «Выход».

Найдите окно программы TrainingCenter и вновь нажмите кнопку «Запустить ПО кодирования» - запустится программа UABUFR. Откройте данные того же выпуска и нажмите кнопку «BUFRII». Программа выдаст сообщение о том, что имеются результаты правки данных выпуска до уровня 100 гПа

Рисунок 21. Запрос на загрузку сохраненных результатов правки

Подтвердите загрузку результатов правки. Найдите в таблице данных уровни от 300 до 257,2 гПа и убедитесь, что недостоверные значения ветра в этом слое забракованы, как и координаты радиозонда в слое с 279,3 по 269,7 гПа. Обратите внимание на цвет точек, которым забракованные значения выводятся на диаграммах с данными ветра и траекторией полета радиозонда, а также на то, как меняется масштабирование этих графиков при установке/снятии отметки «?».

Пример №3:

Подготовьте данные для примера №3 аналогично предыдущим примерам, запустите программу UABUFR и загрузите данные, нажмите кнопку «Выпуск», в диалоге выбора выпуска выберите файл с начальными данными последнего выпуска за текущую дату. Обратите внимание, что при открытии файла INFO будет выдано предупреждение, что кодовые цифры 88 (для радиозондов МРЗ-3А) больше не используются. Подтвердите или введите необходимую информацию, нажмите кнопку «BUFR I» создайте сообщение BUFR c данными до уровня 100 гПа как указано выше. Введите причину прекращения выпуска и нажмите кнопку «BUFRII».

Просмотрите данные выпуска, используя программу «АРХИВ-АП-М». В этом выпуске в конце подъема «зависла» оболочка - данные в конце подъема недостоверны. Необходимо «обрезать» выпуск. Выделите уровни в конце подъема, которые необходимо исключить, нажмите клавишу F2 или кнопку «Урвн(F2)».

В этом выпуске имеется еще и слой со значительным сверхадиабатическим градиентом температуры, связанный с ошибкой обработки высоты в условиях разброса по дальности в слое с 6 до 7 км по высоте. Значения температуры и влажности в этом слое недостоверны. Забракуйте их самостоятельно, после чего нажмите кнопку «ОК» для создания сообщения BUFR с данными всего выпуска.

Обратите внимание, что, если ошибка в данных до уровня 100 гПа обнаружена после завершения выпуска, отправлять исправленное сообщение BUFR c указателем CCx («ЦОР») не нужно. Сразу отправляйте итоговое сообщение с данными всего выпуска с необходимыми правками, т.к. в отличие от кода КН-04 ТЕМП, сообщение BUFR, подаваемое по окончании выпуска содержит все данные этого выпуска.

Рисунок 22. Исключение недостоверных данных температуры

3.5.2. Работа с данными МАРЛ-А без использования файлов prof с данными высокого разрешения

В случае проблем с каналами связи с разрешения Росгидромета допускается отсутствие данных высокого разрешения – в этом случае программа UABUFR вместо файлов prof использует данные из файлов tae3 и rawdata. Перед освоением работы с программой UABUFR в режиме использования данных из файлов tae3 и rawdata, рекомендуется сначала проработать демонстрационные примеры по п. 3.5.1 как указано выше.

После этого завершите программу UABUFR, а затем опять запустите ее из программы TrainingCenter, предварительно сняв отметку «Высокое разрешение», чтобы она вместо файлов prof использовала данные из файлов tae3 и rawdata.

При работе с примерами обратите внимание, что при формировании сообщения BUFR с данными всего выпуска за срок 00 текущего числа (на момент создания демонстрационных примеров) выдается сообщение об ошибке чтения строки в файле TAE3. Нажатие кнопки «Продолжить» продолжить чтение данных, «Прервать» - прервать чтение в текущей позиции и перейти к проверке данных, а «Отменить» - отказаться от продолжения.

Рисунок 23. Посторонние строки в файле TAE3

При формировании сообщения BUFR с данными всего выпуска за срок 12 предыдущего числа (на момент создания демонстрационных примеров) выдается сообщение об отсутстствии файла исходных данных RAW:

Рисунок 24. Предупреждение об отсутствии файла исходных данных RAW

В оперативной работе продолжение допустимо только если ПО «Телеграмма» не может создать файл «RAW».

3.5.3. Работа с данными Вектор-М

Работа с данными Вектор-М при использовании ПО «Телеграмма» для обработки данных ничем, кроме наименования файлов с данными выпусков не отличается от описанной выше работы с данными МАРЛ-А. Для освоения программы UABUFR можно использовать материал, изложенный выше для МАРЛ-А, но при подготовке примеров в программе TrainingCenter следует выбирать пункт «Вектор-М-Телеграмма» - демонстрационные примеры формируются из тех же исходных данных, что и для МАРЛ-А.

Работа с данными Вектор-М при использовании ПО «ЭОЛ» для обработки данных аналогична работе с АВК-АП «ЭОЛ» и отличается помимо наименования файлов с данными выпусков, наличием кодовых цифр радиозонда/системы зондирования в файле info.

3.5.4. Работа с данными АВК-АП «ЭОЛ»

Перед освоением работы с программой UABUFR с данными АВК-АП «ЭОЛ» рекомендуется сначала проработать демонстрационные примеры по п. 3.5.1 и 3.5.2 как указано выше. При работе с демонстрационными примерами для АВК-АП «ЭОЛ» №2 и 3 обратите внимание на соответственно недостоверные данные температуры и ветра.

3.5.5. Работа с данными АВК-АРМ Аэролога

Перед освоением работы с программой UABUFR с данными АВК-АРМ Аэролога рекомендуется сначала проработать демонстрационные примеры по п. 3.5.1 как указано выше.

[1] Количество файлов может изменяться в зависимости от версии ПО


UABUFRTrain.doc/05.04.2017 ПО UABUFR: Руководство по освоению программы

1